Moodle
  1. Moodle
  2. MDL-28649

Student skip content page: Force new attempt and force completed don't work

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.3, 2.1.1, 2.2
    • Fix Version/s: 2.0.5, 2.1.2
    • Component/s: SCORM
    • Labels:
    • Environment:
      Windows Webserver 2008 R2;
      IIS7.5
      "php version 5.2.8 is required and you are running 5.3.6"
      "database mysql version 5.0.25 is required and you are running 5.5.12"
    • Database:
      MySQL
    • Testing Instructions:

      Please, test this both under STABLE branch (one of 2.0/2.1) and master.
      use this SCORM:
      http://moodle.org/mod/data/view.php?d=50&rid=1655

      • Use the following settings form the Scorm activity:
        number of attempts: unlimited
        Force completed: Yes
        Force new attempt: Yes
        Student skip content structure page: Always
      • login as a student (teacher doesn't skipview)
      • attempt the scorm - at end press "exit" link in top right or just return to course homepage
      • attempt the scorm again - press exit or return to course homepage
      • do it again if you want to.
      • log back in as teacher and check reports page to make sure multiple attempts are registered against the user you logged in as above.
      Show
      Please, test this both under STABLE branch (one of 2.0/2.1) and master. use this SCORM: http://moodle.org/mod/data/view.php?d=50&rid=1655 Use the following settings form the Scorm activity: number of attempts: unlimited Force completed: Yes Force new attempt: Yes Student skip content structure page: Always login as a student (teacher doesn't skipview) attempt the scorm - at end press "exit" link in top right or just return to course homepage attempt the scorm again - press exit or return to course homepage do it again if you want to. log back in as teacher and check reports page to make sure multiple attempts are registered against the user you logged in as above.
    • Workaround:

      Set Student skip content structure page to Never

      Show
      Set Student skip content structure page to Never
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull Master Branch:
      master_MDL-28649
    • Rank:
      18425

      Description

      We use Moodle 2.0.3 (Build: 20110505). The Scorm Content is generated with Articulate quizmaker '09.

      The problem I'm having is that Moodle keeps recording the results of different attempts into one attempt. To actually see the attempt status, I should also set "Students skip content page" to Never (which in our course we have set to Allways, for style reasons). When I did this, I noticed that the problem didn't occur any longer. But when I switch back to "Students always skip content page", the problem reoccurs.

      More info and download of logs/scormpackage, see: http://moodle.org/mod/forum/discuss.php?d=182612
      I've also put all the files (logs and Scormpackage) in ProblemStudentSkipContentPage.zip

        Issue Links

          Activity

          Dan Marsden added a comment -

          here's a patch that should resolve it but I haven't tested it yet - if you have time (and are able to apply the patch) can you please take a look and see if it resolves your issue?

          thanks!

          Sytske van Hasselt added a comment -

          I'm not sure if I have time today, but i'll give it a go tomorrow or the day after.
          And sorry for my silly question: which one of the links is the patch?

          Dan Marsden added a comment -

          Hi Sytske - use the "Pull Diff URL" for the version you have - 2.0, 2.1 or 2.2 (master)

          thanks!

          Sytske van Hasselt added a comment -
          Sytske van Hasselt added a comment -

          Ach, i meant: https://github.com/danmarsden/moodle/compare/MOODLE_20_STABLE...m20_MDL-28649
          For we use Moodle 2.0.3, sorry for the mixup...

          Dan Marsden added a comment -

          just did some testing here and it all seems to work - submitting for integration. - thanks!

          Sytske van Hasselt added a comment -

          Hello Dan,
          I'm not very 'coding savy', and i'm not quite sure i have the right files.
          If i understand the information on https://github.com/danmarsden/moodle/compare/MOODLE_20_STABLE...m20_MDL-28649 correctly, you have made changes to 2 files (mod/scorm/locallib.php and mod/scorm/view.php).

          So i would guess i would have to download the code of these changed files, and put these in our mod/scorm-folder.

          But if I download the source from https://github.com/danmarsden/moodle/blob/0dd1a7cb66a8076f51f11ce3272e4df6dc8d3f89/mod/scorm/locallib.php, using the "downloads"-button (which downloads danmarsden-moodle-0dd1a7c.zip), and if I then compare the mod\scorm folder from that zip to our own, I see many more differences than just these two files. I used Beyond Compare to do the comparison.

          for now I'm just going to install just these two mentioned files (locallib and view), and see if my problem is solved. or should i replace more files?

          Sytske

          Sytske van Hasselt added a comment -

          I'm afraid i'm not able to apply the patch. Installing the two files from your sources doesn't have the right result.
          and i'm afraid i can't just insert the changes in our version of mod/scorm/locallib.php and mod/scorm/view.php, because the 'removed' code differs from the code in our version of the files.
          I'm afraid i'll have to wait for the next release, and run the update on our whole moodle installation.

          Thanks for the quick resolve, though!
          groeten,

          sytske

          Eloy Lafuente (stronk7) added a comment -

          Integrated, thanks!

          Rossiani Wijaya added a comment -

          Hi Dan have question with this scorm's attempt.

          I set the scorm according to the testing instruction. while testing it I did this:

          attempt #1: complete the attempt until it reach the last page. (grade is recorded as attempt #1, track details status is complete)
          attempt #2: exit the attempt before it reach the last page (grade is recorded as attempt #2, track details status is incomplete)
          attempt #3: complete the attempt until it reach the last page. (grade is recorded as attempt #3, track details status is complete)
          attempt #4: complete the attempt until it reach the last page. (grade is recorded as attempt #3, track details status is complete)
          attempt #5: complete the attempt until it reach the last page. (grade is recorded as attempt #3, track details status is complete)
          
          Note: grade received for attempt #4 and #5, will keep overwriting the grade for attempt #3.
          

          I noticed that if a student has incomplete attempt, the next following attempts will not be recorded as separate attempt. It will just overwrite the the last attempt.

          I'm not quite familiar with scorm, but I don't think this behavior is correct.

          Dan Marsden added a comment -

          HI Rossiana,

          in attempt 4/5 does it save the grade? - or does it just report the grade received in 3? - I suspect it's entering the SCORM in "review" mode..

          Dan Marsden added a comment -

          just tested this again and couldn't reproduce any issues with attempts.

          The attempts grading method may be causing confusion here - the attempts grading method can be set to first, last, average or highest settings.
          The best way to verify that a new attempt has been created is to look at the reports page and check to see if the attempts number.

          thanks!

          Dan Marsden added a comment -

          looking at this again - forcecompletion isn't very well defined and doesn't quite do what you expect.

          also forcenewattempt will only work if the SCORM is "complete" - so I've created MDL-28985 to tidy this up a bit - I'll try to sort this out this week.

          To test this issue you will need to manually complete each attempt by finishing the short fruit quiz.

          thanks to everyone for the help!

          Eloy Lafuente (stronk7) added a comment -

          Passing this, I've tried the SCORM 3 times, completing it always and revisiting it from the breadcrumb, from the course page and after clicking "exit" and the 3 attempts were saved properly.

          More work clarification will arrive with MDL-28985... so done.

          Eloy Lafuente (stronk7) added a comment -

          Closing, this is now part of Moodle. Big thanks!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: