Moodle
  1. Moodle
  2. MDL-28676

No check is made for mysqli extension in Environment report

    Details

    • Testing Instructions:
      Hide

      1/ install 1.9 site on mysql
      2/ go to env check
      3/ verify all future 2.x versions show mysqli as required php extension
      4/ install 1.9. on pg
      5/ verify mysqli is not require for 2.x upgrades

      Show
      1/ install 1.9 site on mysql 2/ go to env check 3/ verify all future 2.x versions show mysqli as required php extension 4/ install 1.9. on pg 5/ verify mysqli is not require for 2.x upgrades
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Pull from Repository:

      Description

      The 'mysqli' extension (as opposed to the old mysql extension) is a requirement in Moodle 2.0 onwards. No indication is made of this at all in the environment check. I think this really should be added.

        Gliffy Diagrams

          Activity

          Hide
          Michael de Raadt added a comment -

          Thanks for reporting this.

          I've put it on our backlog and we'll try to get to it as soon as we can.

          Show
          Michael de Raadt added a comment - Thanks for reporting this. I've put it on our backlog and we'll try to get to it as soon as we can.
          Hide
          Petr Skoda added a comment -

          Thanks for the report, hopefully the brute force hack introduced in the patch will resolve this.

          To integrators: please note it is not necessary to change 2.x because without the mysqli driver users do not get to the env page anyway.

          Show
          Petr Skoda added a comment - Thanks for the report, hopefully the brute force hack introduced in the patch will resolve this. To integrators: please note it is not necessary to change 2.x because without the mysqli driver users do not get to the env page anyway.
          Hide
          Aparup Banerjee added a comment -

          a ping out to Dan Marsden here.

          Show
          Aparup Banerjee added a comment - a ping out to Dan Marsden here.
          Hide
          Dan Marsden added a comment -

          heh - looks good to me! - looks like a good thing to add.

          Show
          Dan Marsden added a comment - heh - looks good to me! - looks like a good thing to add.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Show
          Eloy Lafuente (stronk7) added a comment - The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week. TIA and ciao
          Hide
          Dan Poltawski added a comment -

          Integrated this, thanks

          Show
          Dan Poltawski added a comment - Integrated this, thanks
          Hide
          Dan Poltawski added a comment -

          I tested this and looks good.

          However I encoutnered some weird problems doing postgres install on 1.9. I didn't spend too much time investigaing on this because well, we are only supporting security there officially.

          Petr/Dan have you managed to install 1.9 on postgres recently?

          Show
          Dan Poltawski added a comment - I tested this and looks good. However I encoutnered some weird problems doing postgres install on 1.9. I didn't spend too much time investigaing on this because well, we are only supporting security there officially. Petr/Dan have you managed to install 1.9 on postgres recently?
          Hide
          Petr Skoda added a comment -

          I guess you need to tweak pg settings a bit in new versions to make it work without problems, it was designed mostly for 8.0...

          Show
          Petr Skoda added a comment - I guess you need to tweak pg settings a bit in new versions to make it work without problems, it was designed mostly for 8.0...
          Hide
          Eloy Lafuente (stronk7) added a comment -

          This issue has been integrated upstream and is now available both via git and cvs (and in some hours, via mirrors and downloads).

          Thanks!

          Show
          Eloy Lafuente (stronk7) added a comment - This issue has been integrated upstream and is now available both via git and cvs (and in some hours, via mirrors and downloads). Thanks!

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: