Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.4, 2.1.1, 2.2
    • Fix Version/s: 2.0.5, 2.1.2
    • Component/s: Chat
    • Labels:
    • Environment:
      Any
    • Database:
      Any
    • Testing Instructions:
      Hide
      1. login as admin
      2. make sure to use basic theme
      3. create chat activity
      4. start error_log on terminal
      5. 'Click here to enter the chat now'

      make sure on error_log terminal there is no file does not exist error for /moodle/mod/chat/gui_ajax/theme/compact/chat.css

      Show
      login as admin make sure to use basic theme create chat activity start error_log on terminal 'Click here to enter the chat now' make sure on error_log terminal there is no file does not exist error for /moodle/mod/chat/gui_ajax/theme/compact/chat.css
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:
    • Rank:
      18349

      Description

      The default theme for the chat module, compact, is missing a file. Error log contains this, over and over during a chat session:

      [Tue Aug 09 14:29:36 2011] [error] [client 74.137.209.228] File does not exist: C:/Apache2/htdocs/moodle/mod/chat/gui_ajax/theme/compact/input.png, referer: /moodle/mod/chat/gui_ajax/theme/compact/chat.css

      I've checked a fresh download and input.png is missing.

        Issue Links

          Activity

          Hide
          Michael de Raadt added a comment -

          Thanks for reporting this.

          I've put it on our backlog and we'll try to get to it as soon as we can.

          Could you please provide replication instructions? That will help us and other users.

          Show
          Michael de Raadt added a comment - Thanks for reporting this. I've put it on our backlog and we'll try to get to it as soon as we can. Could you please provide replication instructions? That will help us and other users.
          Hide
          Ryan Smith added a comment -

          Replication: Just start a chat, make sure you are using the default theme, compact.

          If you look in /mod/chat/gui_ajax/theme/compact/chat.css you'll see:

          background:#FFFFFF url(input.png)

          input.png is not located in that same folder, so it throws the above error in the error log. This should be a simple fix.

          Show
          Ryan Smith added a comment - Replication: Just start a chat, make sure you are using the default theme, compact. If you look in /mod/chat/gui_ajax/theme/compact/chat.css you'll see: background:#FFFFFF url(input.png) input.png is not located in that same folder, so it throws the above error in the error log. This should be a simple fix.
          Hide
          Dongsheng Cai added a comment -

          Hello Ryan

          yes, that file is missing from compact theme.

          Ideally the chat theme should use moodle module renderer, this chat theming thing was created before we implemented theme and output renderer, it should be fixed in the future.

          Show
          Dongsheng Cai added a comment - Hello Ryan yes, that file is missing from compact theme. Ideally the chat theme should use moodle module renderer, this chat theming thing was created before we implemented theme and output renderer, it should be fixed in the future.
          Hide
          Michael de Raadt added a comment -

          We might have to go for a simple fix in the meantime.

          Show
          Michael de Raadt added a comment - We might have to go for a simple fix in the meantime.
          Hide
          Rossiani Wijaya added a comment -

          For a simple fix, copying input.png from bubbles themes.

          Show
          Rossiani Wijaya added a comment - For a simple fix, copying input.png from bubbles themes.
          Hide
          Rajesh Taneja added a comment -

          Looks Good Rossie
          Probably, you can open another bug for fixing "chat theme not using the moodle module renderer"...

          Show
          Rajesh Taneja added a comment - Looks Good Rossie Probably, you can open another bug for fixing "chat theme not using the moodle module renderer"...
          Hide
          Rossiani Wijaya added a comment -

          Thanks Raj.

          MDL-29204 has been created to fix the issue properly.

          Submitting for integration.

          Show
          Rossiani Wijaya added a comment - Thanks Raj. MDL-29204 has been created to fix the issue properly. Submitting for integration.
          Hide
          Sam Hemelryk added a comment -

          Hi Rosie,
          The changes look fine to me however it looks as though this file is missing in MOODLE_20_STABLE as well. Does this fix need to be backported to 20?
          Once I've heard from you I'll integrate and cherry-pick if required.

          Cheers
          Sam

          Show
          Sam Hemelryk added a comment - Hi Rosie, The changes look fine to me however it looks as though this file is missing in MOODLE_20_STABLE as well. Does this fix need to be backported to 20? Once I've heard from you I'll integrate and cherry-pick if required. Cheers Sam
          Hide
          Rossiani Wijaya added a comment -

          Hi Sam,

          Yes, it needs to be backported to 20_stable too. I just added a patch for m20 (https://github.com/rwijaya/moodle/compare/MOODLE_20_STABLE...MDL-28689_m20).

          Thanks.

          Show
          Rossiani Wijaya added a comment - Hi Sam, Yes, it needs to be backported to 20_stable too. I just added a patch for m20 ( https://github.com/rwijaya/moodle/compare/MOODLE_20_STABLE...MDL-28689_m20 ). Thanks.
          Hide
          Sam Hemelryk added a comment -

          Thanks Rosie, this has been integrated now

          Show
          Sam Hemelryk added a comment - Thanks Rosie, this has been integrated now
          Hide
          Aparup Banerjee added a comment -

          couldn't replicate the error for some unknown reason but this works for me.

          Show
          Aparup Banerjee added a comment - couldn't replicate the error for some unknown reason but this works for me.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          git & cvs repositories updated with your gorgeous code. Many thanks!

          Closing and ciao

          Show
          Eloy Lafuente (stronk7) added a comment - git & cvs repositories updated with your gorgeous code. Many thanks! Closing and ciao

            People

            • Votes:
              4 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: