Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-28693

Error when moving question

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Cannot Reproduce
    • 2.1.1
    • None
    • Questions
    • MySQL
    • MOODLE_21_STABLE

    Description

      Go into the question bank and click the 'move' icon next to a question. It looks like an up/down arrow. On the next screen click the "Move question(s)" button. The following error is displayed.

      Notice: Undefined offset: 0 in /home/andrew/Desktop/integration/master/question/type/numerical/edit_numerical_form.php on line 264
      Call Stack

      1. Time Memory Function Location
        1 0.0011 839280 {main}

        ( ) ../question.php:0
        2 0.2502 44852032 moodleform->get_data( ) ../question.php:227
        3 0.2502 44852032 moodleform->is_validated( ) ../formslib.php:498
        4 0.2502 44852112 moodleform->validate_defined_fields( ) ../formslib.php:411
        5 0.2529 44860296 qtype_numerical_edit_form->validation( ) ../formslib.php:452
        6 0.2529 44860608 qtype_numerical_edit_form->validate_answers( ) ../edit_numerical_form.php:241

      Note that I have not created any question categories so all my questions are in "Default for (course name) (3)".

      Attachments

        Issue Links

          Activity

            People

              timhunt Tim Hunt
              andyjdavis Andrew Davis
              Safat Shahin, Tim Hunt, Andrew Lyons, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: