Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-28723

undefined index 'blocks' in upgrading page.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.13, 2.0.4
    • Fix Version/s: 1.9.14, 2.0.5
    • Component/s: Installation
    • Labels:
    • Testing Instructions:

      Make sure you can upgrade and the plugins overview screen does not produce any PHP Notices.

      Show
      Make sure you can upgrade and the plugins overview screen does not produce any PHP Notices.
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE
    • Pull from Repository:

      Description

      upon upgrading errors seen: (ah, just realised that this may have been due to a borked install during development though , Edit: it wasn't.)

      Notice: Undefined index: blocks in /home/aparup/mcode/20/mysql/lib/adminlib.php on line 6261
       
      Call Stack:
          0.0011     893608   1. {main}() /home/aparup/mcode/20/mysql/admin/index.php:0
          0.2224   32934696   2. print_plugin_tables() /home/aparup/mcode/20/mysql/admin/index.php:263
       
       
      Warning: in_array() expects parameter 2 to be array, null given in /home/aparup/mcode/20/mysql/lib/adminlib.php on line 6261
       
      Call Stack:
          0.0011     893608   1. {main}() /home/aparup/mcode/20/mysql/admin/index.php:0
          0.2224   32934696   2. print_plugin_tables() /home/aparup/mcode/20/mysql/admin/index.php:263
          0.2398   34217600   3. in_array() /home/aparup/mcode/20/mysql/lib/adminlib.php:6261
       
       
      Notice: Undefined index: blocks in /home/aparup/mcode/20/mysql/lib/adminlib.php on line 6273
       
      Call Stack:
          0.0011     893608   1. {main}() /home/aparup/mcode/20/mysql/admin/index.php:0
          0.2224   32934696   2. print_plugin_tables() /home/aparup/mcode/20/mysql/admin/index.php:263
       
       
      Warning: array_search() expects parameter 2 to be array, null given in /home/aparup/mcode/20/mysql/lib/adminlib.php on line 6273
       
      Call Stack:
          0.0011     893608   1. {main}() /home/aparup/mcode/20/mysql/admin/index.php:0
          0.2224   32934696   2. print_plugin_tables() /home/aparup/mcode/20/mysql/admin/index.php:263
          0.2480   34217648   3. array_search() /home/aparup/mcode/20/mysql/lib/adminlib.php:6273

        Gliffy Diagrams

          Attachments

            Activity

            salvetore Michael de Raadt added a comment -

            Um... Is this something that could be reproduced?

            nebgor Aparup Banerjee added a comment -

            Hopefully someone can verify that. otherwise feel free to close although the warnings didn't come with any other warnings that would have hinted towards a borked installation.

            salvetore Michael de Raadt added a comment -

            OK. So the issue is that the upgrade code is not behaving well when it the blocks array is empty.

            David, could you have a quick look at this?

            mudrd8mz David Mudrák added a comment -

            This affects 2.0 and 1.9 only as the plugins overview screen was rewritten for 2.1. Thanks Apu for spotting this.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            nebgor Aparup Banerjee added a comment -

            Thanks David! That's been integrated.

            samhemelryk Sam Hemelryk added a comment -

            Thanks guys - tests passed

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Many thanks for the hard work, this has been sent upstream and is available in all the git and cvs repositories.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Oct/11