Moodle
  1. Moodle
  2. MDL-28968

Quiz wrongly inherites attempt delay setting from pre-requisite quiz

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.4
    • Fix Version/s: None
    • Component/s: Quiz
    • Labels:
      None
    • Database:
      MySQL
    • Testing Instructions:

      1. Create Quiz 1 with enforced delays as depicted in the screenshot 'delayQuiz1.png'
      2. Create Quiz 2 with enforced delays as depicted in the screenshot 'delayQuiz2.png' and Grade condition as depicted in the screenshot 'RestrictAccessQuiz2.png'
      3. Fail Quiz 1 on first attempt.
      4. Fail Quiz 1 on second attempt.
      5. Pass Quiz 1 on third attempt with grade at least 70%.
      6. Fail Quiz 2 on first attempt.
      7. Attempt Quiz 2 the second time.

      Show
      1. Create Quiz 1 with enforced delays as depicted in the screenshot 'delayQuiz1.png' 2. Create Quiz 2 with enforced delays as depicted in the screenshot 'delayQuiz2.png' and Grade condition as depicted in the screenshot 'RestrictAccessQuiz2.png' 3. Fail Quiz 1 on first attempt. 4. Fail Quiz 1 on second attempt. 5. Pass Quiz 1 on third attempt with grade at least 70%. 6. Fail Quiz 2 on first attempt. 7. Attempt Quiz 2 the second time.
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      18517

      Description

      Students who fail the first attempt of Quiz 1 are locked out for 10 minutes (Enforced delay between 1st and 2nd attempts of Quiz 1). Then when they fail the second attempt, they are locked out for 6 hours (Enforced delay between later attempts of Quiz 1). They may then pass the 3rd attempt and able to unlock Quiz 2 if the grade of Quiz 1 is at least 70%.
      When they attempt Quiz 2 for the first time, and fail it, they are locked out for 6 hours before the second attempt of Quiz 2 (Enforced delay between later attempts of Quiz 1 and also Quiz 2). The delay is supposed to be 10 minutes (Enforced delay between 1st and 2nd attempts of Quiz 2).

      1. RestrictAccessQuiz2.xcf
        158 kB
        Adi Tedjasaputra
      1. delayQuiz1.png
        79 kB
      2. delayQuiz2.png
        79 kB
      3. RestrictAccessQuiz2.png
        50 kB

        Activity

        Michael de Raadt added a comment -

        Thanks for reporting this.

        I've put it on our backlog and we'll try to get to it as soon as we can.

        In the meantime feel free to help us work on this issue.

        Sam Marshall added a comment -

        I'm going to reassign this as a quiz issue because I doubt it is related to conditional access. It might be there is some issue with the quiz settings that cause it (e.g.) not to assign a grade until after a delay, therefore making the condition not true until after the delay. Or something.

        Tim Hunt added a comment - - edited

        I am sorry, but I don't understand. The symptoms you describe are completely impossible given how the quiz code works. The 'delay between attempts' feature treats different quizzes completely independently.

        Can you test again, and make sure that what you describe is really happening.

        Adi Tedjasaputra added a comment -

        I have tested this case with different parameters on Moodle 2.1.3+ (Build 20111223) without success in replicating the problem. The client hasn't reported a similar problem since upgraded to Moodle 2.0.6+ (Build 20111201). I am currently requesting another live test on their Moodle installation. Please feel free to close this ticket if you don't hear from me within four weeks.

        Tim Hunt added a comment -

        Thanks for the update.

        Tim Hunt added a comment -

        Closing, as per Adi's last comment.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: