Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-28971

Moodle upgrade fails because of undefined constant SCORM_TOC_DISABLED

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.4
    • Fix Version/s: 2.0.5
    • Component/s: SCORM
    • Labels:
    • Environment:
      RedHat
    • Database:
      PostgreSQL
    • Testing Instructions:

      After this issue has been fixed an upgrade from a Moodle version previous to 13 Jul to a current Moodle version should run through without problems.

      Show
      After this issue has been fixed an upgrade from a Moodle version previous to 13 Jul to a current Moodle version should run through without problems.
    • Workaround:

      The attached patch provides a quick fix for the problem.

      Show
      The attached patch provides a quick fix for the problem.
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      An upgrade to the latest Moodle version fails because the constant SCORM_TOC_DISABLED in mod/scorm/db/upgrade.php is not defined.
      Reproduce:
      The change in upgrade.php has been introduced on Jul 13th so you need an older Moodle version than that to reproduce

      • add some scorm content
      • upgrade to the latest Moodle code
      • run the Moodle upgrade
      • you will get the following error: ERROR: invalid input syntax for integer: "SCORM_TOC_DISABLED"

      Results:
      Due to this error the upgrade can't finish and Moodle keeps trying to upgrade but fails.

      Expected:
      The upgrade should run through without and error.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              danmarsden Dan Marsden added a comment -

              thanks for the report - that change occured in last weeks build - sorry about that - will try to get it sorted this week.

              danmarsden Dan Marsden added a comment -

              NOTE TO INTEGRATOR - this only occurs in 2.0 branch - not 2.1 or 2.2 - sorry about the regression!

              thanks,

              danmarsden Dan Marsden added a comment -

              adding Eloy - any chance you could squeeze this simple fix (but big blocker) into this weeks integration?
              grr... too many branches to maintain!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated, thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Passing this. The change is trivial and the new value (1) is the value in 20_STABLE for hidden tocs - see scorm_get_hidetoc_array().

              stronk7 Eloy Lafuente (stronk7) added a comment -

              This has been sent upstream and is now available in all git & cvs servers. Many thanks for the hard work!


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    10/Oct/11