Moodle
  1. Moodle
  2. MDL-28976

Broken fragment id #q0 added to the URL when navigating around the quiz

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.1, 2.2
    • Fix Version/s: 2.1.2
    • Component/s: Quiz
    • Labels:
    • Rank:
      18664

      Description

      I can't read my own PHPdoc comments. I was passing 0 when it should have been null.

        Issue Links

          Activity

          Hide
          Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Show
          Eloy Lafuente (stronk7) added a comment - The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week. TIA and ciao
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Uhm...

          is https://github.com/timhunt/moodle/compare/master...MDL-28976#L2R421 correct?
          (the replacement from id to slot in the first param?)

          Just confirm and I'll be happy to integrate, TIA!

          Show
          Eloy Lafuente (stronk7) added a comment - Uhm... is https://github.com/timhunt/moodle/compare/master...MDL-28976#L2R421 correct? (the replacement from id to slot in the first param?) Just confirm and I'll be happy to integrate, TIA!
          Hide
          Tim Hunt added a comment -

          Yes. Definitely right. Serious screw up by some idiot in Milton Keynes that it was still saying $questoinid some months after the 2.1 release. The API changed with the new question engine, and this fix is necessary.

          Show
          Tim Hunt added a comment - Yes. Definitely right. Serious screw up by some idiot in Milton Keynes that it was still saying $questoinid some months after the 2.1 release. The API changed with the new question engine, and this fix is necessary.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Integrated, thanks!

          Show
          Eloy Lafuente (stronk7) added a comment - Integrated, thanks!
          Hide
          Andrew Davis added a comment -

          Hi Tim. Just ran through your testing instructions and I seem to still be getting #q0 at the end of the URL during review. I'm attaching a screenshot.

          Show
          Andrew Davis added a comment - Hi Tim. Just ran through your testing instructions and I seem to still be getting #q0 at the end of the URL during review. I'm attaching a screenshot.
          Hide
          Tim Hunt added a comment -

          Well, OK. but the think about a hyperlink is it does not no good to see a screenshot that shows you that after you clicked a link, you ended up in the wrong place.

          I really need to know where the link you clicked way, because that is where the remaining problem is.

          Show
          Tim Hunt added a comment - Well, OK. but the think about a hyperlink is it does not no good to see a screenshot that shows you that after you clicked a link, you ended up in the wrong place. I really need to know where the link you clicked way, because that is where the remaining problem is.
          Hide
          Tim Hunt added a comment -

          OK, it is clicking Next to get from one page of the review to the next.

          Show
          Tim Hunt added a comment - OK, it is clicking Next to get from one page of the review to the next.
          Hide
          Tim Hunt added a comment -

          Doh! I did a search on the code for the attemt_url method, but I forgot to the the review_url method.

          Can we pass this one now, and I will make a new bug, for next week, to fix the review URLs.

          Show
          Tim Hunt added a comment - Doh! I did a search on the code for the attemt_url method, but I forgot to the the review_url method. Can we pass this one now, and I will make a new bug, for next week, to fix the review URLs.
          Hide
          Tim Hunt added a comment -

          MDL-29111 created and fix submitted for integration.

          Show
          Tim Hunt added a comment - MDL-29111 created and fix submitted for integration.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Passing this as far as the pending cases (review_url) will be handled by MDL-29111

          Show
          Eloy Lafuente (stronk7) added a comment - Passing this as far as the pending cases (review_url) will be handled by MDL-29111
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Many thanks for the hard work, this has been sent upstream and is available in all the git and cvs repositories.

          Show
          Eloy Lafuente (stronk7) added a comment - Many thanks for the hard work, this has been sent upstream and is available in all the git and cvs repositories.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: