Moodle
  1. Moodle
  2. MDL-28979

Match question type: correct answer display formatted badly

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.1, 2.2
    • Fix Version/s: 2.1.2
    • Component/s: Questions
    • Labels:
    • Testing Instructions:

      1. Create a match question.
      2. Preview it, and make sure the option Right answer is set to shown.
      3. Click Submit all and finish. Verify that the right answer is shown like "The correct answer is: A - a, C - c, B - b, D - d." all one one line, not split over millions of lines.

      Show
      1. Create a match question. 2. Preview it, and make sure the option Right answer is set to shown. 3. Click Submit all and finish. Verify that the right answer is shown like "The correct answer is: A - a, C - c, B - b, D - d." all one one line, not split over millions of lines.
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      The problem is TinyMCE wrapping each subquestion in <p> tags. We need to use CSS to supress that, like with multichoice specific feedback.

        Gliffy Diagrams

          Issue Links

            Activity

            Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            Eloy Lafuente (stronk7) added a comment -

            Blindly integrating this, thanks!

            Rossiani Wijaya added a comment -

            Thanks Tim.

            Test passed.

            Eloy Lafuente (stronk7) added a comment -

            Many thanks for the hard work, this has been sent upstream and is available in all the git and cvs repositories.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: