Moodle
  1. Moodle
  2. MDL-29008

Narrow down the Grade percentage options in the popup Grade listbox

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.9.13, 2.1.1
    • Fix Version/s: None
    • Component/s: Questions, Quiz
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_21_STABLE
    • Rank:
      18551

      Description

      When setting grades for question's options (ex. multi choice)

      Too many teachers open up the grade (percentage) listbox and scroll down to the -100% (minus 100 percent)
      and choose it as the "100%" grade. due to misunderstanding of the UI.

      The Initial popup window of the grade's list is too small to show the "100%" at the top, as the first on the list.
      and the option "83%" shows instead, as the first. so teachers scroll down (for unknown reason!)
      and select the -100% option. wired.

      To prevent this...
      I am suggesting to narrow down the list of options.

      lib/questionlib.php (line 300)

      from :

       
      function get_grade_options() {
          // define basic array of grades
          $grades = array(
              1.00,
              0.90,
              0.83333,
              0.80,
              0.75,
              0.70,
              0.66666,
              0.60,
              0.50,
              0.40,
              0.33333,
              0.30,
              0.25,
              0.20,
              0.16666,
              0.142857,
              0.125,
              0.11111,
              0.10,
              0.05,
              0);
      

      To:

       
      function get_grade_options() {
          // define basic array of grades
          $grades = array(
              1.00,
              0.90,
              0.80,
              0.75,
              0.70,
              0.66666,
              0.60,
              0.50,
              0.40,
              0.33333,
              0.30,
              0.25,
              0.20,
              0.125,
              0.10,
              0.05,
              0);
      

        Activity

        Tim Hunt added a comment -

        You clearly have not looked at Moodle 2.1.1 before filling in Affects version 2.1.1 in your bug report.

        In Moodle 2.1.1 this problem was fixed by moving the None option to the top of the dropdown.

        We cannot remove any of the grade choices. Some people use them. (You are, of course, welcome to hack the list of grades offered in your install. That is the advantage of open source.)

        And, I am not going to make a UI change like this on old stable branches - because they are meant to be stable.

        Nadav Kavalerchik added a comment -

        Thank you for your feedback

        Indeed i did not look in Moodle 2.1.1
        just assumed it was there too.

        I "hacked" 3 Moodle servers and just wanted to suggest this idea, upstream.
        Please discard it if it is unimportant in you pov.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: