Moodle
  1. Moodle
  2. MDL-29042

Single topic forum doesn't support groups

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 1.9.13, 2.0.4, 2.1.1
    • Fix Version/s: None
    • Component/s: Forum, Groups
    • Labels:
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE, MOODLE_21_STABLE
    • Rank:
      18573

      Description

      Create a single topic forum and activate groups.
      If separate groups are active students can't answer to the initial post.
      If visible groups are active, students can answer in all groups even if they are not enrolled in the group.

      I think there are several options to solve this:
      In single topic forum the initial post is published separately for each group so group members can answer in their own group only.
      Alternative: In single topic forum group settings are disabled.

        Activity

        Hide
        Michael de Raadt added a comment -

        Thanks for reporting this.

        I've put it on our backlog and we'll try to get to it as soon as we can.

        In the meantime feel free to help us work on this issue.

        Show
        Michael de Raadt added a comment - Thanks for reporting this. I've put it on our backlog and we'll try to get to it as soon as we can. In the meantime feel free to help us work on this issue.
        Hide
        Martin Dougiamas added a comment -

        Using separate groups means we have to have one discussion per group, which means multiple copies of the initial post. This means we need some extra code to update all copies of the initial post whenever the forum activity is updated. Could get a bit hairy but sounds doable.

        Show
        Martin Dougiamas added a comment - Using separate groups means we have to have one discussion per group, which means multiple copies of the initial post. This means we need some extra code to update all copies of the initial post whenever the forum activity is updated. Could get a bit hairy but sounds doable.
        Hide
        Michael de Raadt added a comment -

        Thanks for reporting this issue.

        We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported.

        If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed.

        Michael d.

        TW9vZGxlDQo=

        Show
        Michael de Raadt added a comment - Thanks for reporting this issue. We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported. If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed. Michael d. TW9vZGxlDQo=
        Hide
        Michael de Raadt added a comment -

        I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported.

        This is being done as part of a bulk annual clean-up of issues.

        If you still believe this is an issue in supported versions, please create a new issue.

        Show
        Michael de Raadt added a comment - I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported. This is being done as part of a bulk annual clean-up of issues. If you still believe this is an issue in supported versions, please create a new issue.

          People

          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: