Moodle
  1. Moodle
  2. MDL-29056

Need scroll feature in quiz grading window

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.4, 2.1.1
    • Fix Version/s: 2.0.5, 2.1.2
    • Component/s: Quiz, Themes
    • Labels:
      None
    • Environment:
      php 5.3.6, MySQL 5.1.57
    • Rank:
      18743

      Description

      When I click on a quiz (in order to grade it) I have to rely on being able to size my browser window in order to see the grade column. The browser's horizontal scroll bar does not allow you to scroll to the rightmost column. For quizzes with many questions, this can be a major problem.

      I made this video showing the problem.
      http://www.rjerz.com/v/misc/Quiz_Item_Window_Width_Problem/Quiz_Item_Window_Width_Problem.html

        Activity

        Tim Hunt added a comment -

        Are you running the very latest 2.1.1 weekly build? There was a recent fix that may have solved this.

        Tim Hunt added a comment -

        Specifically MDL-28437 which it seems is included in 2.1.1.

        Please can you say which theme you are using, and attach a screen-grab.

        Rick Jerz added a comment -

        Good question. I am using "Formal-White" theme, and maybe it is really a theme problem. I will do some checking.

        Instead of a simple screen-grab, I instead made a video. Look at my URL and let me know if the video is not playing for you. I tested it, and it seems to work fine.

        Tim Hunt added a comment -

        I just get a black screen on my Mac laptop.

        Rick Jerz added a comment -

        Tim,

        The black screen should eventually show an arrow.

        I just tried build 20110817, and the problem is still there. Then I tried the "standard" theme, and horizontal scrolling seemed to work. So I think that this could be a theme problem (Formal-white). Do you think that I should repost my problem in the "theme" area? Or can you do this?

        Tim Hunt added a comment -

        This does indeed look more like a Formal White issue than a quiz issue. It might be worth looking at some other pages with big reports, like the gradebook, to see if that breaks in the same way.

        Daniele, I think you need to look at how formal white theme handles pages with 'report' layout type.

        Daniele Cordella added a comment - - edited

        Ciao Tim.
        I made my investigation and I found that simple addition of

        .pagelayout-report #page-content .region-content

        { overflow: auto; }

        to one css sheet fixes the problem.

        BUT - BUT - BUT - BUT - BUT - BUT - BUT

        the css style that I need to override comes from the FW parent theme base->pagelayout.css

        My question is: do I need to override the FW style OR the change has to be done in theme base->pagelayout.css?

        If you feel I need to change the style at FW Level, I already pushed to my github repo the three branches: MDL-29056_M20, MDL-29056_M21 and MDL-29056_master.

        Let me know, please, as far as you can because next two weeks I will be forced far from the web.
        Ciao and thanks all.

        Daniele Cordella added a comment - - edited

        Please feel free to reopen this issue if you believe the changes have to be done at "base" theme level. (see my last post of 26/Aug/11 4:58 PM)

        Tim Hunt added a comment -

        +1 from me that this patch is good code, and worth committing.

        However, I don't feel qualified to comment on whether this would better be done in base theme.

        Mary Evans added a comment -

        I would say this needs to go into Base theme. But you are OK to add this to FW Danielle as it ensures your theme will work OK.

        Thanks
        Mary

        Eloy Lafuente (stronk7) added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        Mary Evans added a comment -

        I would prefer a patch to be applied to the Base, but would like to see the resent modifications to QUIZ page which Tim has done, to see if it makes any difference first.

        Tim Hunt added a comment -

        I don't think you should close this as deferred. You should leave it open until it is fixed.

        And all the quiz changes I have done are in the 21_STABLE branch, what are you waiting for?

        Mary Evans added a comment -

        Daniele, reading the comments here, it looks like the problem is in the Formal White theme, but as I mentioned to you in the Theme forums discussion, the fact you have 'base' and 'canvas' parent themes the wrong was round in config.php, this in itself may also cause problems with the theme if it is corrected.

        The reason I said what I did earlier about this being done in Base was based on your first comments in the Theme's forum. It appears this earlier assumption of yours was wrong and that the Formal White needs this patch and not Base.

        Sorry for the confusion.

        Just re-base as Eloy recommended and then reset to integration review ready for next week.

        Rick Jerz added a comment -

        Hi Everyone, it's Rick.

        The problem appears to be with the Formal White theme, not the standard (or base). I upgraded my experimental Moodle 2.1 site, and proved that this problem does not exist with the standard them, but does with Formal White. Here's my video again (wait for the play arrow to appear)

        http://www.rjerz.com/v/ex/Quiz_Formal_White/Quiz_Formal_White.html

        Daniele Cordella added a comment -

        Hello all.
        By reading again all the story it seems that this issue only needs to be submitted again for integration.
        Trying to follow the request of Eloy to rebase my pull branches, I will submit for integration again as soon as I can rebase.
        Thanks all.

        Daniele Cordella added a comment -

        I apologise. I can not rebase. Overwhelmed by git errors I can not understand. I give up. Sorry.

        Rick Jerz added a comment -

        Might somebody else be able to do this?

        Mary Evans added a comment -

        I was wondering if I should offer to take this on from Daniele as it is a pain to re-base. It is just as easy doing it from scratch.

        Don't worry Rick it will get done.

        Rick Jerz added a comment -

        Mary, as I have seen some of your great support, I do not doubt that it will get done.

        Thanks.

        Daniele Cordella added a comment -

        Sure it will be done. I restarted from scratch in order to submit for integration as soon as possile. I apologise for the unacceptable delay.

        Daniele Cordella added a comment -

        I started from scratch but, despite this, I am not able to let the comparison with MOODLE_21_STABLE to show properly. I apologise and I started to be bored by git.

        Hope this issue can be closed soon. Thanks all for patience and offers of help.

        Sam Hemelryk added a comment -

        Thank Daniele, this has been integrated now.
        The solution works however it is not the ideal solution as there is still a horizontal scrollbar being shown within the page. The ideal solution would be to fix the layout for the report pagelayout within the formatl_white theme.
        I'll create an issue for this so that sometime in the future we can look at it.

        Cheers
        Sam

        Rick Jerz added a comment -

        Sam, let me know if you want me to test your code. Mary and I were able to work together a lot. She did all the coding. I was able to regularly test her ideas.

        Rossiani Wijaya added a comment -

        Thanks everyone. This looks fine on the site.

        Test passed.

        Daniele Cordella added a comment -

        Thanks Wijaya!

        Daniele Cordella added a comment - - edited

        Sam,
        after our chat few hours ago I went to investigate more this problem to provide a better solution.
        As I told you I prefer my solution to the one provided by standard theme even if it is less usable.
        Your correctly changed my mind because if a page is very long and the scrollbar for the content is at the bottom of the content then the user must scroll all the way to the bottom of the page before being able to scroll horizontally and this makes it very hard to find things in tables that require both horizontal and vertical scrolling.

        What I found now is a solution that is binds together my view point and your.
        Try it by your self and tell me your opinion.

        Do this, please.

        1. Revert the changes introduced with the fix of this same issue.
        Alias: remove

        .pagelayout-report #page-content .region-content {
            overflow: auto;
        }

        from formal_white/style/pagelayout.css

        2. Add to formal_white/style/quiz.css

        #page-mod-quiz-report.pagelayout-report .no-overflow {overflow: auto;}
        

        Go to test the solution and you will find that this new one let me smile and you too.
        With your agreement, please, do not push the first solution tomorrow but this new one. IMO it is really better.
        TIA
        Ciao.

        Eloy Lafuente (stronk7) added a comment -

        YTC !

        (aka, yay, thanks and ciao ) Closing.

        Daniele Cordella added a comment - - edited

        Sam, please, do not forget to give to this issue a minute of your time for a short comment.
        If needed I can clone it and submit for integration with the new found solution.
        Thanks in advance.

        Sam Hemelryk added a comment -

        Hi Daniele,

        I've just been having a look at your purposed solution and a think about it, however there is perhaps a bit more to your original soluition than you recognise.
        The original solution that has now been implemented fixes the overflow for the report layout on ALL pages that use that report layout within Moodle.
        Essentially while this bug had been noticed in the quiz it did exist in several other places as well such as course, admin, and grade reports.

        The fix that you've now purposed fixes the quiz report however it doesn't deal with the larger issue of the reports layout. The other thing to note is that the .no-overflow div that you've used in the style there is only applied around content that has been passed through our formatting functions, presently tables etc rarely get passed through these formatting functions (doing so would break many of them) so unfortunately we couldn't apply that approach globally through Moodle either.

        I think for the time being we are best to stick with what is there is presently.

        Cheers
        Sam


          People

          • Votes:
            2 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: