Moodle
  1. Moodle
  2. MDL-29152

No link to CSS is included in html mail sent to subscribers.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.1.1
    • Fix Version/s: None
    • Component/s: Forum
    • Labels:
      None
    • Environment:
      My site is hosted by hostgator
    • Database:
      MySQL
    • Testing Instructions:
      Hide

      Send a mail to himself and compare email view on the site and email view in mail app.

      Show
      Send a mail to himself and compare email view on the site and email view in mail app.
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      No link to CSS is included in html mail sent to subscribers. The result is that subscribers receive a text-only plus images, without any box, background color, font dimension, ecc.

        Gliffy Diagrams

          Issue Links

            Activity

            Luciano Biondo created issue -
            Luciano Biondo made changes -
            Field Original Value New Value
            Priority Minor [ 4 ] Major [ 3 ]
            Luciano Biondo made changes -
            Difficulty Easy
            Hide
            Michael de Raadt added a comment -

            Hi, Luciano.

            Have you tried to replicate this on another site, such as demo.moodle.net?

            Show
            Michael de Raadt added a comment - Hi, Luciano. Have you tried to replicate this on another site, such as demo.moodle.net?
            Hide
            Luciano Biondo added a comment -

            No, I didn't, because I'm not interested to know if Moodle works well in environments different than mine. I was thinking that Moodle should work well in all environments, as long than requisites are satisfied. In my environment it didn't and I don't know why. If you suggest me any trial I can do to find what's the fault, I will do. I think it would be useful for everyone to discover why Moodle is not working somewhere.

            Regards
            Luciano

            Show
            Luciano Biondo added a comment - No, I didn't, because I'm not interested to know if Moodle works well in environments different than mine. I was thinking that Moodle should work well in all environments, as long than requisites are satisfied. In my environment it didn't and I don't know why. If you suggest me any trial I can do to find what's the fault, I will do. I think it would be useful for everyone to discover why Moodle is not working somewhere. Regards Luciano
            Hide
            Michael de Raadt added a comment -

            For individual support, you might try asking questions on the forums.

            Show
            Michael de Raadt added a comment - For individual support, you might try asking questions on the forums.
            Michael de Raadt made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Resolution Won't Fix [ 2 ]
            Hide
            Ray Lawrence added a comment -

            This has prompted me to flag this up too, I've not got around to it before.

            We have this issue too. See screenshot from Moodle.org post. Mail client is Thunderbird. The loss of formatting in HTML emails isn't great for the user experience.

            Show
            Ray Lawrence added a comment - This has prompted me to flag this up too, I've not got around to it before. We have this issue too. See screenshot from Moodle.org post. Mail client is Thunderbird. The loss of formatting in HTML emails isn't great for the user experience.
            Ray Lawrence made changes -
            Attachment postcss.gif [ 25531 ]
            Ray Lawrence made changes -
            Attachment postcss.gif [ 25532 ]
            Ray Lawrence made changes -
            Comment [ This has prompted me to flag this up too, I've not got around to it before.

            We have this issue too. See screenshot from Moodle.org post. Mail client is Thunderbird. The loss of formatting in HTML emails isn't great for the user experience. ]
            Ray Lawrence made changes -
            Attachment postcss.gif [ 25531 ]
            Hide
            Ray Lawrence added a comment -

            Michael, can you comment/re-open?

            Show
            Ray Lawrence added a comment - Michael, can you comment/re-open?
            Hide
            Matteo Scaramuccia added a comment -

            Looking at the code, mod/forum/lib.php::forum_make_mail_html():

            ...
                $posthtml = '<head>';
            /*    foreach ($CFG->stylesheets as $stylesheet) {
                    //TODO: MDL-21120
                    $posthtml .= '<link rel="stylesheet" type="text/css" href="'.$stylesheet.'" />'."\n";
                }*/
                $posthtml .= '</head>';
            ...
            

            it seems to me a link to MDL-21120 to be required too.

            HTH,
            Matteo

            Show
            Matteo Scaramuccia added a comment - Looking at the code, mod/forum/lib.php::forum_make_mail_html() : ... $posthtml = '<head>'; /* foreach ($CFG->stylesheets as $stylesheet) { //TODO: MDL-21120 $posthtml .= '<link rel="stylesheet" type="text/css" href="'.$stylesheet.'" />'."\n"; }*/ $posthtml .= '</head>'; ... it seems to me a link to MDL-21120 to be required too. HTH, Matteo
            Michael de Raadt made changes -
            Link This issue will be resolved by MDL-29738 [ MDL-29738 ]

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: