Moodle
  1. Moodle
  2. MDL-29181

Grades Entered with Quick Grading Not Saving

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.0.4
    • Fix Version/s: None
    • Component/s: Gradebook
    • Labels:
    • Database:
      PostgreSQL
    • Workaround:

      1. Using Edit grade function.
      2. setting paging below the threshold for unsaved grades.
      3. Using an Offline Assignment to enter grades.

      Show
      1. Using Edit grade function. 2. setting paging below the threshold for unsaved grades. 3. Using an Offline Assignment to enter grades.
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      18729

      Description

      When a Teacher enters grades into Grader Report with Quick Grading, the first 15-30 grades in a column will save, but any subsequent grades on that page will not save. The same number of grades save in each column for a particular course. This behavior affects all courses on our system, but each course may have a different number (betwen 15-30) of grades that will be saved--even if the same students are enrolled in two different courses. If the paging for the grade book is set so that there is more than one page of students, each page will be able save the top 15-30 grades. Also, clicking on the edit grade icon for a particular cell and entering grades individually allows all grades to be saved as expected. This has been widely replicated on both Mac OSX with different versions of Safari and Firefox and Windows 7 with various versions of IE and Firefox.

      Replication instructions:

      1. Set up a course with over 50 students.
      2. Go to Grade Administration > Grader Report.
      3. Enter grades for one column using Quick Grading in the Grader report view (any column type will work).
      4. Click update.
        The top 15-30 grades will be saved and the rest of the cells will be blank.

        Issue Links

          Activity

          Michael de Raadt added a comment -

          Thanks for reporting this.

          I've put it on our backlog and we'll try to get to it as soon as we can.

          In the meantime adding more information, such as screenshots or even a code solution, will help us and other users.

          Andrew Caldwell added a comment -

          I have been regularly noticing a similar problem. I have set up several of my student workers as non-editing teachers. All my student workers grade using their iPads as we are an iPad school. Sometimes when two or more student workers are grading an assignment, only one student's assigned grades and comments will show. I have seen this happen on multiple occasions. This requires that either I or my students go back and regrade all of the assignments graded previously, a very time consuming task. The problem is that the original grades appear on the student's iPads as they are grading in Quickgrade but will not appear later or on other iPads.

          Andrew Davis added a comment -

          There is some forum discussion of a somewhat similar sounding problem. http://moodle.org/mod/forum/discuss.php?d=195431

          Michael de Raadt added a comment -

          This looks to have been duplicated a number of times now. Please contributed to MDL-26275.


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: