Moodle
  1. Moodle
  2. MDL-29266

Quick grading assignment notification checkbox is always checked

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.1, 2.2, 2.3
    • Fix Version/s: 2.1.4, 2.2.1
    • Component/s: Assignment (2.2)
    • Labels:
    • Testing Instructions:

      1. Go to an assignment's submissions page ('View x submitted assignments')
      2. Check the 'Allow quick grading' box and save preferences.
      3. Change a grade or enter a comment
      4. Uncheck the 'Send notifications' box
      5. Press the 'Save all my feedback' button

      Verify that when the page reloads, the 'Send notifications' remains unchecked.

      6. Check the 'Send notifications' box
      7. Press the 'Save all my feedback' button

      Verify that when the page reloads, the 'Send notifications' remains checked.

      Show
      1. Go to an assignment's submissions page ('View x submitted assignments') 2. Check the 'Allow quick grading' box and save preferences. 3. Change a grade or enter a comment 4. Uncheck the 'Send notifications' box 5. Press the 'Save all my feedback' button Verify that when the page reloads, the 'Send notifications' remains unchecked. 6. Check the 'Send notifications' box 7. Press the 'Save all my feedback' button Verify that when the page reloads, the 'Send notifications' remains checked.
    • Workaround:

      Uncheck the 'Send notifications' box every time.

      Show
      Uncheck the 'Send notifications' box every time.
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:
    • Rank:
      18810

      Description

      On the main submissions page, in quick grading mode, the 'Send notifications' checkbox is always checked, even if the user has previously unchecked the box. This leads to unintended notification emails to students.

      Replication instructions:

      1. Go to an assignment's submissions page ('View x submitted assignments')
      2. Check the 'Allow quick grading' box and save preferences.
      3. Change a grade or enter a comment
      4. Uncheck the 'Send notifications' box
      5. Press the 'Save all my feedback' button

      When the page reloads, the 'Send notifications' box is checked again

        Activity

        Michael de Raadt added a comment - - edited

        It is unclear to me if this setting is intended to have its state maintained between page loads.

        It may be that the default is to always to send feedback, but there may be occasions when you want to avoid it, then when you return to the form again, the default returns. This equates to bypassing the cooling off period after posting a forum message. If this is the intended behaviour, perhaps it could be clarified by some label/help rewording.

        Andrew Davis added a comment -

        This may well have a relationship with MDL-27990 which was fixed in the final days before 2.1 was released. Im not currently able to see what code changes were made as part of that issue as the software managing that is currently being upgraded.

        The checkbox should be getting its value from a user preference so when you uncheck it it should remain unchecked.

        Robert Northcutt added a comment -

        This should be changed. In 1.9+ you could uncheck and save as part of preferences. In 2.1+ you cannot save as unchecked. When entering grades across multiple classes I typically do not want to send notifications. I try to remember to uncheck each time, but as with all manual tasks, I sometimes forget.

        A nuisance that should be fixed.

        Henning Bostelmann added a comment -

        This bug can be fixed with a small code modification, see git branch as above. (In line 630 of mod/assignment/lib.php, the code erroneously tries to store NULL instead of 0 as the new preference value.)

        Henning Bostelmann added a comment -

        I'm putting this up for peer review. Fix provided for master only, but needs to be cherry-picked to all 2.x branches.

        Ankit Agarwal added a comment -

        Hi,
        Looks good to me!
        Thanks for fixing this!

        Henning Bostelmann added a comment -

        Hi Ankit, thanks for reviewing. Can you send the fix to integration review? Unfortunately I don't have access to that button.

        Ankit Agarwal added a comment -

        submitted!
        Thanks

        Eloy Lafuente (stronk7) added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        Sam Hemelryk added a comment -

        Thanks guys,

        I've just been looking at this now and the changes look good.
        I'll integrate this once the next integration cycle starts (later today or tomorrow).

        Cheers
        Sam

        Sam Hemelryk added a comment -

        Thanks Henning this has been integrated now

        Rossiani Wijaya added a comment -

        This is working fine.

        Thanks for fixing.

        Test passed.

        Eloy Lafuente (stronk7) added a comment -

        The git and cvs repositories are happy receiving your very first contribution to Moodle for 2012. Happy new year!

        Closing, ciao


          People

          • Votes:
            5 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: