Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29336

Grade mapping table not entirely saved when using Number of Errors Acessment Form with weights different from 1

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.4, 2.1.1, 2.2
    • Fix Version/s: 2.0.5, 2.1.2
    • Component/s: Workshop
    • Labels:
    • Environment:
      LAMP
    • Testing Instructions:
      • TEST: Follow the steps to reproduce and make sure that all mappings are saved
      • Change the field weights to "1", re-save the form and continue in editing
      • Change the field weights back to "2" and "5", re-save the form
      • TEST: Make sure that only the first two mappings were preserved. When the form was saved with two dimensions each having the weight "1", the mappings for 3 and more errors were removed.
      Show
      TEST: Follow the steps to reproduce and make sure that all mappings are saved Change the field weights to "1", re-save the form and continue in editing Change the field weights back to "2" and "5", re-save the form TEST: Make sure that only the first two mappings were preserved. When the form was saved with two dimensions each having the weight "1", the mappings for 3 and more errors were removed.
    • Workaround:

      1 - Press Blanks for 2 more assertions until you have the same or a bigger number off assertions than the maximum number of possible errors. In the above testing instrucions, the max errrors were 7, so you must press twice until you have 8 Assertions.
      2 - Edit the grading table as desired and press Save and Continue Editing. This time every data was recordered.

      However there is a problem with this workarround. The number of Assertions gets back to 4, because Assertions 5 to 8 were left empty. So if you need to edit the form again, you must add the needed new assertions again to avoid the occurrence of the same problem.

      Show
      1 - Press Blanks for 2 more assertions until you have the same or a bigger number off assertions than the maximum number of possible errors. In the above testing instrucions, the max errrors were 7, so you must press twice until you have 8 Assertions. 2 - Edit the grading table as desired and press Save and Continue Editing. This time every data was recordered. However there is a problem with this workarround. The number of Assertions gets back to 4, because Assertions 5 to 8 were left empty. So if you need to edit the form again, you must add the needed new assertions again to avoid the occurrence of the same problem.
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-29336-numerrors-mapping

      Description

      When you configure a Number of Errors Acessment Form with some weights different from 1, the grade mapping table extends to consider the possible maximum number of errors, as it should. However when you save the form some values configured on the grade mapping table are not saved, only the first values are saved.

      Replication steps:

      1. Add a Workshop in a course
      2. Configure the mandatory information (Workshop name, Introduction and Submission settings) and set Grading strategy to Number of errors and press the Save and Display button
      3. Edit the acessment form and define 2 Assertions with something on the description and configure the weights to 2 and 5
      4. Press Save and Continue editing. Result: The grade mapping table allows grading values for 7 possible errors, which is consistent with the weights 2 and 5 and the resulting possible number of errors: 0, 2, 5 or 7.
      5. Select grades for the errors exactly as sugested: 85%, 71%, 57%, 42%, 28%, 14%, 0% and press Save and Continue Editing.
      6. Go down to the Grade Mapping Table and you will see that only the 4 first values were recorded and the last 3 were ignored.

      The problems seems to be that only the exact number of Assertions being shown is being recordered, as you can see on the suggested workarround.

        Gliffy Diagrams

          Attachments

          1. Image1.jpg
            Image1.jpg
            21 kB
          2. Image2.jpg
            Image2.jpg
            20 kB
          3. Image4.jpg
            Image4.jpg
            56 kB

            Activity

            salvetore Michael de Raadt added a comment -

            Thanks for reporting this.

            I've put it on our backlog and we'll try to get to it as soon as we can.

            In the meantime adding more information, such as screenshots or even a code solution, will help us and other users. If you do add a solution, please add a 'patch' label.

            timhunt Tim Hunt added a comment -

            Micheal, did you even bother to read the bug report before adding your standard "In the meantime adding more information, such as screenshots" copy-and-paste! This is a perfect bug-report already.

            avilela Antonio Vilela added a comment -

            Tim, thanks for considering my bug-report as perfect . Howerver I must say that I added the screenshots after michael's comment.Thanks

            mudrd8mz David Mudrák added a comment -

            Submitting for integration. Thanks Antonio for reporting this - very well spotted and described!

            samhemelryk Sam Hemelryk added a comment -

            Thanks David, this has been integrated now

            andyjdavis Andrew Davis added a comment -

            Works as expected.

            nebgor Aparup Banerjee added a comment -

            fixes have been rolled merrily up the stream! Thanks everybody!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Oct/11