Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29378

survey-COLLES (Preferred) and survey-COLLES (Actual) are not different from survey-COLLES (Preferred and Actual)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0, 2.1, 2.2
    • Fix Version/s: 2.4.7, 2.5.3
    • Component/s: Survey
    • Labels:
      None
    • Testing Instructions:

      Testing difficulty: easy

      1. Create all possible surveys in a course - one Critical Incidents survey, three COLLES surveys (Preferred, Actual and both) and one ATTLS survey.
      2. Fill all the surveys by couple of course participants (students).
      3. As a teacher, make sure that correct responses are saved (you may want to somehow remember how each student filled the form) and can be downloaded correctly.
      Show
      Testing difficulty: easy Create all possible surveys in a course - one Critical Incidents survey, three COLLES surveys (Preferred, Actual and both) and one ATTLS survey. Fill all the surveys by couple of course participants (students). As a teacher, make sure that correct responses are saved (you may want to somehow remember how each student filled the form) and can be downloaded correctly.
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-29378-survey

      Description

      I do not remember how it should be but for sure they can not be equals.
      Probably, they used to have a lot of "I prefer that" and "I find that" .... or something like that.
      It may be matter of checking old lang files only.

        Gliffy Diagrams

          Issue Links

            Activity

            dougiamas Martin Dougiamas added a comment -

            Yes there is a nasty regression here. I can't believe it's not been noticed more before now!!

            It should look like this http://surveylearning.moodle.com/mod/survey/view.php?id=3

            rezeau Joseph Rézeau added a comment -

            Martin "I can't believe it's not been noticed more before now!"
            Maybe this has not been noticed because the Survey activity is hardly ever used by moodlers, given its non-customizable nature.

            dougiamas Martin Dougiamas added a comment -

            Thanks Joseph, helpful.

            mudrd8mz David Mudrak added a comment -

            given its non-customizable nature

            Well. The other view might be that COLLES is a standardized survey tool, with its own beackground in research, methodology, data processing and everything. Many people think that any questionnaire they quickly sum up would produce good data. Often, having a standard as a reference has real benefits.

            rezeau Joseph Rézeau added a comment -

            @Martin and David,
            I was not questioning the validity of the Moodle COLLES survey activity, only pointing out that, from what I gather from the moodle.org Survey forum, it seems to be rarely used as is, and most posters would like to be able to customize it.
            Which is in fact what is going to happen in the forthcoming Survey2 module, which will combine the standard COLLES survey with fully customizable surveys.
            Joseph

            mudrd8mz David Mudrak added a comment -

            This is a regression caused by 5196df589b0fbcead4a0943c8e7b227f8a98c897

            mudrd8mz David Mudrak added a comment -

            So, I have somewhat progress here. It's really hard to deduct what Andrew was describing in the commit message of the regressive change. But when his patch is reverted, both "I prefer that" and "I found that" lines appear again. It's apparent that the patch is wrong as the subquestion's type does not determine if there should be one or two answer lines. It's always the parent (master) question (such as "collesm1") whose type determines this. But I would really like to understand Andrew's reasons for the change.

            As usually, other issues raise as one starts to play with it. Apparently, since MDL-7501, rows are not highlighted any more (see the file reverted.png). I'm not really sure that the suggested fix in MDL-7501 was good. If nothing, than the multi COLLES now has at least 48 items and not 24 as the description says. However, I tried to fix the row classes calculation too. The result is in reverted+highlighted.png file.

            dougiamas Martin Dougiamas added a comment - - edited

            I think Reverted+highlighted looks OK. It's certainly much better and usable enough. And probably accessible too.

            So assuming that the results all get saved and results are stored/shown correctly then my +1 for it!

            mudrd8mz David Mudrak added a comment -

            Submitting form integration. See commit messages for more explanation.

            samhemelryk Sam Hemelryk added a comment -

            Thanks David this has been integrated now.

            rezeau Joseph Rézeau added a comment -

            Tested the fix in Moodle 2.5, looks OK to me.

            mudrd8mz David Mudrak added a comment -

            Argh! Sam Hemelryk, I just realized there was a trivial mistake in the integrated branch yet. I added yet another commit on top of each branch. Can you please re-emerge them or alternatively cherry-pick the last commit with the message "MDL-29378 Fix the recent string modification". I'm sorry.

            samhemelryk Sam Hemelryk added a comment -

            No probs David, I've integrated the updated branches now

            marina Marina Glancy added a comment -

            wow, this took a long time to test. All surveys are working fine.

            I noticed that the whole UI of surveys is so unfriendly, but I'm not going to create any issues because it's not likely that it is widely used anyway

            damyon Damyon Wiese added a comment -

            This issue along with 77 of it's friends has been sent upstream and released to the world.

            Thankyou for your contribution.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Nov/13