Moodle
  1. Moodle
  2. MDL-29405

Teacher can allocate peer assessment when the workshop is configured without the Use peer assessment setting

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Not a bug
    • Affects Version/s: 2.1.1
    • Fix Version/s: None
    • Component/s: Workshop
    • Labels:
    • Environment:
      LAMP
    • Testing Instructions:

      In a course with 2 or more students:
      1 - Create a workshop not activating the options Use peer assessment and Students may assess their own work.
      2 - Move the workshop to the Submission Phase
      3 - Login as a student and submit work
      4 - Login as teacher and the Allocate submissions link is available. It should not be available because the workshop was configured without self and peer assessment.

      Continue to test the student ability to assess peer work
      5 - Click on the Allocate submissions link and process some alocation
      6 - Login as a student and he will be able to assess the allocated submissions

      Show
      In a course with 2 or more students: 1 - Create a workshop not activating the options Use peer assessment and Students may assess their own work. 2 - Move the workshop to the Submission Phase 3 - Login as a student and submit work 4 - Login as teacher and the Allocate submissions link is available. It should not be available because the workshop was configured without self and peer assessment. Continue to test the student ability to assess peer work 5 - Click on the Allocate submissions link and process some alocation 6 - Login as a student and he will be able to assess the allocated submissions
    • Workaround:

      Teacher should ignore the allocation and skip the assessment phase.

      Show
      Teacher should ignore the allocation and skip the assessment phase.
    • Affected Branches:
      MOODLE_21_STABLE
    • Rank:
      18923

      Description

      Teacher can allocate submissions to peer assessment and students can assess peer submissions when the workshop is configured without the Use peer assessment setting. These actions should be unavailable.

        Activity

        Michael de Raadt added a comment -

        Thanks for reporting this.

        Perhaps David could comment if this is expected behaviour or a bug.

        David Mudrak added a comment -

        Sorry, closing this as Not a bug. That checkbox is actually sort of experimental flag that does not do much yet. The original idea was that when the peer assessment is disabled, the workshop UI would be simplified for users (students) so that the workshop looks and feels like an assignment (no assessment and evaluation phase for them etc). But we did not manage to finish this so the checkbox is there but its impact is really minimal. I still want to keep it though as it indicates whether the teacher expects peer assessment or not. So in the future, when this feature is finally implemented, it would start work.

        Note that we can't disable allocations anyway. Allocation is a process that creates a blank assessment record between a submission and the reviewer (marker). So even if the submissions are assessed by teacher only, they are actually allocated. Also note, when a teacher has a group of assistants who help him/her with assessing, they still need to allocate submissions to them - even when the real peer assessment among students does not happen.

        Hope it explains and thanks for the report!


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: