Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29423

Deprecated: Assigning the return value of new by reference is deprecated

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.9.13
    • Fix Version/s: None
    • Component/s: Other
    • Labels:
    • Database:
      MySQL
    • Workaround:
      Hide

      in \moodle\course\modedit.php on line 187
      remove the "&"

      Show
      in \moodle\course\modedit.php on line 187 remove the "&"
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      When creating a new Activity in moodle 1.9 with debug mode ON, we are getting this error warning:
      Deprecated: Assigning the return value of new by reference is deprecated in \moodle\course\modedit.php on line 187

        Gliffy Diagrams

          Attachments

            Activity

            rezeau Joseph Rézeau created issue -
            Hide
            ray Ray Lawrence added a comment -

            Same here Moodle 1.9.13+ (Build: 20111007)

            PHP 5.3.6

            Show
            ray Ray Lawrence added a comment - Same here Moodle 1.9.13+ (Build: 20111007) PHP 5.3.6
            ray Ray Lawrence made changes -
            Field Original Value New Value
            Priority Minor [ 4 ] Major [ 3 ]
            Database [MySQL]
            ray Ray Lawrence made changes -
            Labels partner
            dougiamas Martin Dougiamas made changes -
            Assignee Martin Dougiamas [ dougiamas ] moodle.com [ moodle.com ]
            skodak Petr Skoda made changes -
            Assignee moodle.com [ moodle.com ] Petr Škoda (skodak) [ skodak ]
            Hide
            skodak Petr Skoda added a comment -

            Hello, Moodle 1.9.x was not designed to be compatible with PHP 5.3, we fixed only critical issues that were breaking it. Please disable all notices and warnings in your installation and try to consider upgrading to Moodle 2.2.

            Petr

            Show
            skodak Petr Skoda added a comment - Hello, Moodle 1.9.x was not designed to be compatible with PHP 5.3, we fixed only critical issues that were breaking it. Please disable all notices and warnings in your installation and try to consider upgrading to Moodle 2.2. Petr
            skodak Petr Skoda made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Resolution Won't Fix [ 2 ]
            Hide
            rezeau Joseph Rézeau added a comment -

            OK, thanks for the info, Petr
            Joseph

            Show
            rezeau Joseph Rézeau added a comment - OK, thanks for the info, Petr Joseph

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: