Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29462

html_to_text('0') gives '', not '0'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.13, 2.0.4, 2.1.1, 2.2
    • Fix Version/s: 1.9.14, 2.0.5, 2.1.2
    • Component/s: Libraries
    • Labels:
    • Testing Instructions:
      Hide

      1. Run the unit tests in lib/simpletest/testweblib.php

      Note that there are two failures on 1.9 which are nothing to do with this change.

      I cannot suggest a way to test this through the UI. (The place I saw this in the UI was in an OU custom question type.)

      Show
      1. Run the unit tests in lib/simpletest/testweblib.php Note that there are two failures on 1.9 which are nothing to do with this change. I cannot suggest a way to test this through the UI. (The place I saw this in the UI was in an OU custom question type.)
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE, MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Attachments

        Activity

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Fix Release Date:
              10/Oct/11