Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29489

PARAM_URL accepts "http://" as a valid url

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.1.1
    • Fix Version/s: None
    • Component/s: Forms Library, Libraries
    • Labels:
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      http:// and https:// (only these words without any suffix) are considered as valid urls by PARAM_URL filter.

      IMO there are no valid use-cases for these and they should not pass validations.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              Hide
              stronk7 Eloy Lafuente (stronk7) added a comment -

              Moving out from this, sending to STABLE backlog. Ciao

              Show
              stronk7 Eloy Lafuente (stronk7) added a comment - Moving out from this, sending to STABLE backlog. Ciao
              Hide
              salvetore Michael de Raadt added a comment -

              Thanks for reporting this issue.

              We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported.

              If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed.

              Michael d.

              TW9vZGxlDQo=

              Show
              salvetore Michael de Raadt added a comment - Thanks for reporting this issue. We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported. If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed. Michael d. TW9vZGxlDQo=
              Hide
              salvetore Michael de Raadt added a comment -

              I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported.

              This is being done as part of a bulk annual clean-up of issues.

              If you still believe this is an issue in supported versions, please create a new issue.

              Show
              salvetore Michael de Raadt added a comment - I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported. This is being done as part of a bulk annual clean-up of issues. If you still believe this is an issue in supported versions, please create a new issue.

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: