Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29535

borked context filter settings after change in PARAM_ALPHAEXT

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0, 2.1
    • Fix Version/s: 2.0.5, 2.1.2
    • Component/s: Filters
    • Labels:
      None
    • Testing Instructions:

      None of the core filters use the code that is affected by this change.

      To test it, you need to create a simple filter plugin that uses http://docs.moodle.org/dev/Filters_2.0#Local_configuration.

      Then test that you can, in fact, edit and save the local configuration for the filter.

      Show
      None of the core filters use the code that is affected by this change. To test it, you need to create a simple filter plugin that uses http://docs.moodle.org/dev/Filters_2.0#Local_configuration . Then test that you can, in fact, edit and save the local configuration for the filter.
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:

      Description

      no core filters are affected, that is why this was not reported yet I suppose, thanks Eloy for discovering it while working on review of MDL-29504

      most probably my fault

        Gliffy Diagrams

          Issue Links

            Activity

            skodak Petr Skoda created issue -
            skodak Petr Skoda made changes -
            Field Original Value New Value
            Link This issue is a regression caused by MDL-15897 [ MDL-15897 ]
            skodak Petr Skoda made changes -
            Assignee Eloy Lafuente (stronk7) [ stronk7 ] Petr Škoda (skodak) [ skodak ]
            skodak Petr Skoda made changes -
            Description no core filters are affected, that is why this was not reported yet I suppose, thanks Eloy for discovering it while working on review of MDL-29504 no core filters are affected, that is why this was not reported yet I suppose, thanks Eloy for discovering it while working on review of MDL-29504

            most probably my fault
            skodak Petr Skoda made changes -
            Status Open [ 1 ] Waiting for integration review [ 10010 ]
            Pull 2.0 Diff URL https://github.com/skodak/moodle/compare/MOODLE_20_STABLE...w38_MDL-29535_m20_filters
            Pull from Repository git://github.com/skodak/moodle.git
            Pull 2.0 Branch w38_MDL-29535_m20_filters
            Fix Version/s 2.2 [ 10656 ]
            Testing Instructions no idea how to test it, core does not use this, maybe it would be easier to ask Tim
            Pull 2.1 Branch w38_MDL-29535_m21_filters
            Pull 2.1 Diff URL https://github.com/skodak/moodle/compare/MOODLE_21_STABLE...w38_MDL-29535_m21_filters
            skodak Petr Skoda made changes -
            Fix Version/s 2.0.5 [ 10950 ]
            Fix Version/s 2.1.2 [ 10851 ]
            Fix Version/s 2.2 [ 10656 ]
            Affects Version/s 2.1 [ 10370 ]
            Affects Version/s 2.0 [ 10122 ]
            Affects Version/s 2.1.1 [ 10750 ]
            skodak Petr Skoda added a comment - - edited

            to integrators: fix for master is already in MDL-29504, please cherry pick if that gets rejected, thanks

            stronk7 Eloy Lafuente (stronk7) made changes -
            Currently in integration Yes
            stronk7 Eloy Lafuente (stronk7) made changes -
            Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
            Integrator stronk7
            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks!

            stronk7 Eloy Lafuente (stronk7) made changes -
            Status Integration review in progress [ 10004 ] Waiting for testing [ 10005 ]
            nebgor Aparup Banerjee added a comment -

            have performed the test : 'ask Tim'

            timhunt Tim Hunt made changes -
            Testing Instructions no idea how to test it, core does not use this, maybe it would be easier to ask Tim None of the core filters use the code that is affected by this change.

            To test it, you need to create a simple filter plugin that uses http://docs.moodle.org/dev/Filters_2.0#Local_configuration.

            Then test that you can, in fact, edit and save the local configuration for the filter.
            nebgor Aparup Banerjee made changes -
            Status Waiting for testing [ 10005 ] Testing in progress [ 10011 ]
            Tester nebgor
            nebgor Aparup Banerjee added a comment -

            Hello worldS, this works for me. Thanks for the test Tim. (more mojitos)

            nebgor Aparup Banerjee made changes -
            Status Testing in progress [ 10011 ] Tested [ 10006 ]
            nebgor Aparup Banerjee added a comment -

            fixes have been rolled merrily up the stream! Thanks everybody!

            nebgor Aparup Banerjee made changes -
            Status Tested [ 10006 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]
            Currently in integration Yes
            Integration date 28/Sep/11

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Oct/11