Moodle
  1. Moodle
  2. MDL-29541

Backport MDL-29244 to stable branches

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.4, 2.1.1, 2.2
    • Fix Version/s: 2.0.5, 2.1.2
    • Component/s: Administration
    • Labels:
      None
    • Testing Instructions:

      1. Log in as admin
      2. Create 2 users who have never logged in (if not already present)
      3. Go to user bulk action page (Site administration -> Users -> Bulk user actions)
      4. Click "Show advanced"
      5. Select "Never Accessed" and click "Add Filter"
      6. Make sure the "Never Accessed" filter is visible and "Users" should contain both the users (which were created in step 2)
      7. Click on "Remove all filters"
      8. Repeat step 4 - 7, witch "Never modified" option
      9. Repeat step 4 - 7, witch "Never modified" and "Never accessed" option
      10. Login as user1 and logout
      11. Log in as admin and repeat 1-9, in case of "Never modified" both the users should be visible and in case of "Never accessed" only one user2 should be visible
      12. Log in as another user and "Edit profile" (Settings -> My profile settings -> Edit profile)
      13. Log in as admin and repeat 1-9, in case of "Never modified" user1 should be visible and in case of "Never accessed" user2 should be visible and in "Never accessed" and "Never modified" neither one should be visible
      14. Assign user1 as teacher of course and repeat step 3 and 4
      15. In "Course role" select Teacher and click Add filter
      16. user1 should be visible
      17. click "Remove all filters" and repeat 14 and 15 with specific category and make sure right user is visible.
      Note:
      Make sure to check it on 20 branch.

      Show
      1. Log in as admin 2. Create 2 users who have never logged in (if not already present) 3. Go to user bulk action page (Site administration -> Users -> Bulk user actions) 4. Click "Show advanced" 5. Select "Never Accessed" and click "Add Filter" 6. Make sure the "Never Accessed" filter is visible and "Users" should contain both the users (which were created in step 2) 7. Click on "Remove all filters" 8. Repeat step 4 - 7, witch "Never modified" option 9. Repeat step 4 - 7, witch "Never modified" and "Never accessed" option 10. Login as user1 and logout 11. Log in as admin and repeat 1-9, in case of "Never modified" both the users should be visible and in case of "Never accessed" only one user2 should be visible 12. Log in as another user and "Edit profile" (Settings -> My profile settings -> Edit profile) 13. Log in as admin and repeat 1-9, in case of "Never modified" user1 should be visible and in case of "Never accessed" user2 should be visible and in "Never accessed" and "Never modified" neither one should be visible 14. Assign user1 as teacher of course and repeat step 3 and 4 15. In "Course role" select Teacher and click Add filter 16. user1 should be visible 17. click "Remove all filters" and repeat 14 and 15 with specific category and make sure right user is visible. Note: Make sure to check it on 20 branch.
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull Master Branch:
      wip-mdl-29244
    • Rank:
      19019

      Description

      Backport MDL-29244 to stable branches

        Issue Links

          Activity

          Rajesh Taneja added a comment -
          Aparup Banerjee added a comment -

          Correct me if I'm wrong but this isn't really duplicate of MDL-29543. It seems Andrew picked up a new issue while testing master.

          Rajesh Taneja added a comment -

          Yeah Aparup,

          Sorry, I read wrongly

          Aparup Banerjee added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and cheers!

          Rajesh Taneja added a comment -

          Branches rebased.

          Sam Hemelryk added a comment -

          Stopping this review and making Apu the integrator of this seeing as he was the integrator of the original issue.

          Just noting that the PHPdoc comments for the file are a copy and paste mistake perhaps should be fixed now in all branches - or as a separate issue. I'll leave up to you fella's.

          Cheers
          Sam

          Rajesh Taneja added a comment -

          Thanks for pointing this Sam
          Fixed all branches. Added master to reflect doc changes. No need for testing on master (only comments are updated on master)

          Aparup Banerjee added a comment - - edited

          Thank you Rajesh

          This has been integrated and is up for testing mainly in stable branches.
          (ps: fixed very minor whitespace)

          Andrew Davis added a comment -

          tested successfully in 2.0 stable

          Eloy Lafuente (stronk7) added a comment -

          git repositories have been updated with your awesome changes, thanks! Closing.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: