Moodle
  1. Moodle
  2. MDL-29542

Lesson gets corrupted after creating a new question

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.5, 2.1.2, 2.2
    • Fix Version/s: 2.0.6, 2.1.3
    • Component/s: Lesson
    • Labels:
      None
    • Testing Instructions:
      Hide

      1. Create a lesson activity
      2. Add a question page
      3. Select "short answer/multi-choice" and click "Add a question page"
      4. Enter values and click "Add a question page"
      5. Error should not be visible.
      6. Navigate to course and select lesson, it should not shows WSD with error message

      Show
      1. Create a lesson activity 2. Add a question page 3. Select "short answer/multi-choice" and click "Add a question page" 4. Enter values and click "Add a question page" 5. Error should not be visible. 6. Navigate to course and select lesson, it should not shows WSD with error message
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:
    • Rank:
      19021

      Description

      1. Create a lesson activity
      2. Add a question page
      3. Select "short answer/multi-choice" and click "Add a question page"
      4. Enter values and click "Add a question page"
      5. Error is visible.
      6. Navigate to course and select lesson, it shows WSD with error message

        Issue Links

          Activity

          Hide
          Rajesh Taneja added a comment -

          Increasing the priority as lesson breaks on master

          Show
          Rajesh Taneja added a comment - Increasing the priority as lesson breaks on master
          Hide
          Rajesh Taneja added a comment -

          https://github.com/skodak/moodle/compare/master...w38_MDL-29401_m22_frankenstyle#L37R726

          qType is int.

          mod/lesson/locallib.php line 726
          $mform->setType('qtype', PARAM_PLUGIN);
          
          Show
          Rajesh Taneja added a comment - https://github.com/skodak/moodle/compare/master...w38_MDL-29401_m22_frankenstyle#L37R726 qType is int. mod/lesson/locallib.php line 726 $mform->setType('qtype', PARAM_PLUGIN);
          Hide
          Ankit Agarwal added a comment -

          Hi Rosie,
          Looks good to me!
          Thanks

          Show
          Ankit Agarwal added a comment - Hi Rosie, Looks good to me! Thanks
          Hide
          Rossiani Wijaya added a comment -

          Thanks Ankit for reviewing.

          Submitting for integration review.

          Show
          Rossiani Wijaya added a comment - Thanks Ankit for reviewing. Submitting for integration review.
          Hide
          Aparup Banerjee added a comment -

          Thanks all, this has been integrated

          Show
          Aparup Banerjee added a comment - Thanks all, this has been integrated
          Hide
          Sam Hemelryk added a comment -

          Thanks guys - passed

          Show
          Sam Hemelryk added a comment - Thanks guys - passed
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Done, your delicious hacks have been sent upstream, many thanks!

          Closing as fixed, ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Done, your delicious hacks have been sent upstream, many thanks! Closing as fixed, ciao

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: