Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29581

File upload doesn't work if maxbytes set to 'Server Limit'

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Won't Fix
    • Affects Version/s: 2.1.1
    • Fix Version/s: None
    • Component/s: Files API
    • Labels:
      None
    • Database:
      MySQL
    • Workaround:
      Hide

      Workaround is to manually set maxbytes, but this doesn't work since we need maxbytes set to Server Limit for large files.

      Show
      Workaround is to manually set maxbytes, but this doesn't work since we need maxbytes set to Server Limit for large files.
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      The mobile app will not upload content if the maxbytes setting in the Site Policies is set to 'Server Limit'.

      I have upload_max_filesize = 1024M, and post_max_size = 1024M. Setting maxbytes to Server Limit allows us to upload very large files or large course backups.

      With that set, I try to upload a recording, and it records, and I click Send and it says "This audio file is 92.3 KB" and click upload. I get the message "This file is bigger than the maximum size".

      Once I set the maxbytes setting manually, to say, 10 MB, it allows me to upload the file correctly.

        Gliffy Diagrams

          Activity

          Hide
          jerome Jérôme Mouneyrac added a comment -

          I moved this issue as a MDL. It's a STABLE backlog issue.

          Show
          jerome Jérôme Mouneyrac added a comment - I moved this issue as a MDL. It's a STABLE backlog issue.
          Hide
          salvetore Michael de Raadt added a comment -

          Thanks for reporting this issue.

          We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported.

          If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed.

          Michael d.

          TW9vZGxlDQo=

          Show
          salvetore Michael de Raadt added a comment - Thanks for reporting this issue. We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported. If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed. Michael d. TW9vZGxlDQo=
          Hide
          salvetore Michael de Raadt added a comment -

          I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported.

          This is being done as part of a bulk annual clean-up of issues.

          If you still believe this is an issue in supported versions, please create a new issue.

          Show
          salvetore Michael de Raadt added a comment - I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported. This is being done as part of a bulk annual clean-up of issues. If you still believe this is an issue in supported versions, please create a new issue.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: