Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29621

XHTML not welformed when creating Feedback questions

    Details

    • Testing Instructions:
      Hide

      1. Log in as admin/teacher
      2. Enable XML strict headers under "Settings -> Site administration -> Development -> debugging"
      3. Create feedback activity.
      4. Goto Edit questions tab of feedback and try to add any question type (information ,label etc).
      5. This did generate an error.

      Show
      1. Log in as admin/teacher 2. Enable XML strict headers under "Settings -> Site administration -> Development -> debugging" 3. Create feedback activity. 4. Goto Edit questions tab of feedback and try to add any question type (information ,label etc). 5. This did generate an error.
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-29621_master_wip

      Description

      while testing MDL-29539, I found that XHTML breaks while creating questions for a feedback activity

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            grabs Andreas Grabs added a comment -

            Thank you for reporting this!

            Show
            grabs Andreas Grabs added a comment - Thank you for reporting this!
            Hide
            samhemelryk Sam Hemelryk added a comment -

            Thanks Andreas this has been integrated now

            Show
            samhemelryk Sam Hemelryk added a comment - Thanks Andreas this has been integrated now
            Hide
            ankit_frenz Ankit Agarwal added a comment -

            Hi,
            That was fast

            On an unrelated note shouldn't the "question" field in feedback > edit questions > add a question > information
            be required?

            Rest stuff works as expected.
            test passed.
            Thanks

            Show
            ankit_frenz Ankit Agarwal added a comment - Hi, That was fast On an unrelated note shouldn't the "question" field in feedback > edit questions > add a question > information be required? Rest stuff works as expected. test passed. Thanks
            Hide
            stronk7 Eloy Lafuente (stronk7) added a comment -

            git repositories have been updated with your awesome changes, thanks! Closing.

            Show
            stronk7 Eloy Lafuente (stronk7) added a comment - git repositories have been updated with your awesome changes, thanks! Closing.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Oct/11