Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0, 2.1, 2.1.1
    • Fix Version/s: 2.0.6, 2.1.3
    • Component/s: Repositories
    • Labels:
      None
    • Database:
      Any
    • Testing Instructions:

      1) Enable Google Docs Repository in the proper manor
      2) Go to Upload file and choose Google Docs
      3) Login and Authorize
      4) No files are displayed

      Show
      1) Enable Google Docs Repository in the proper manor 2) Go to Upload file and choose Google Docs 3) Login and Authorize 4) No files are displayed
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:

      Description

      It seems that something has changed (possibly on Googles side) that has broken the Google Docs Repository.
      No files are being displayed after granting access via the Google Docs Popup.
      Others are reporting the same issue here:

      http://moodle.org/mod/forum/discuss.php?d=187099

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              jfilip Justin Filip added a comment -

              I can confirm this is happening on at least versions:

              • 2.0.4+ (Build: 20110817)
              • 2.1.1+ (Build: 20110925)
              kfortin Kathryn Fortin added a comment -

              We have reproduced this issue on multiple sites on the 2.0.3 build: 20110511

              clampman Chris Lampman added a comment -

              We have experienced the same issue in the last week. We recently did a theme installation on our course development site and the day after we lost the connection to our Google Docs repository. With Instructional Designers around the country relying on our repository this is a major issue for us. It worked fine up until that installation. Not sure if the two are related.We are running 2.1.3

              martin.gertsch Martin Gertsch added a comment -

              For me to, it is happening on at least versions:

              2.0.4+ (Build: 20110817)
              2.1.1+ (Build: 20110925)

              dongsheng Dongsheng Cai added a comment -

              Re-assign to Dan, because dan is the expert on google docs api.

              poltawski Dan Poltawski added a comment -

              Hi All, can anyone confirm if this just stopped working on sites, or if it was related to a Moodle change.

              i.e. did anyone 'do nothing' and find that the repository stopped working?

              poltawski Dan Poltawski added a comment -

              OK - to answer my own question I see files are not available on a site I know worked.

              poltawski Dan Poltawski added a comment -

              So it appears that this breakage has been caused by Google enforcing use of SSL urls. This is understandable, although i'm sure they didn't support SSL when I first implemented the google integration.

              I am pushing the fix for integration.

              In the meantime, to fix this on your sites, you can apply this patch:
              https://git.luns.net.uk/?p=moodle.git;a=commitdiff_plain;h=0b2d555f1a095a7b5dbc2572fa8678f21be11c25

              poltawski Dan Poltawski added a comment -

              Integrators, this patch can (and should) be cherry-picked onto 20_STABLE and master too.

              cmurad Chris Murad added a comment -

              Thanks
              I have applied the patch and confirm it fixed the issue

              stronk7 Eloy Lafuente (stronk7) added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              samhemelryk Sam Hemelryk added a comment -

              Thanks guys this has been integrated now.

              Check out http://www.theregister.co.uk/2011/03/18/google_apis_require_ssl/ its about the decision Google made to require developers to access their API's through SSL back in march, coming into effect 15th September.

              Cheers
              Sam

              phalacee Jason Fowler added a comment -

              Testing passed in latest integration versions 2.0 2.1 and Master

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Many thanks for the hard work developing and testing this. It has been spread to cvs and git upstream repositories.

              Closing, ciao


                People

                • Votes:
                  22 Vote for this issue
                  Watchers:
                  10 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    28/Nov/11