Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29724

update login page layout for all themes.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.3
    • Component/s: Themes
    • Labels:
      None
    • Testing Instructions:

      Go to moodlehead/login/index.php.
      You should see something like what is in new_arrangement.png attachment

      make sure to test it on all themes. (login as admin to change site theme).

      Show
      Go to moodlehead/login/index.php. You should see something like what is in new_arrangement.png attachment make sure to test it on all themes. (login as admin to change site theme).
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      While testing MDL-29640, I noticed other themes such as: Nimble, Arialist, Binarius, and FormFactor are still in old layout arrangement.

      For consistency purpose, the new layout should apply for the rest of themes.

        Gliffy Diagrams

          Issue Links

            Activity

            daniss Daniele Cordella added a comment -

            during the development of this fix, if it will planned to move css selectors at "central level", it must be taken into account to remove "local" styles from single themes already fixing this issue by their own (sorry for my English)

            lazydaisy Mary Evans added a comment -

            @Daniele

            Are you saying that if the corrected CSS for the LOGIN page are done in BASE theme then all the login CSS should be removed from CORE themes?

            Ciao
            Mary

            lazydaisy Mary Evans added a comment -

            I am intending deleting all related login CSS from Canvas theme as this seems to be causing the regression in this new style login layout. And as Base core.css takes care of this new arrangement, then no need to re-invent the wheel in Canvas. At the end of the day, this situation only relates to those themes which use Canvas as a Parent Theme anyway, but rules out Formal White as this theme has been fixed in the theme already.

            Thanks

            lazydaisy Mary Evans added a comment -

            @Sam

            Also fixed in this are:
            Arialist theme login pagelayout CSS was not picking up for .content-only layout
            Splash theme slight adjustment for styling to match theme design for two collumn layout by adding background image to .signuppanel, and making border-left: 1px solid #ddd;

            Cheers
            Mary

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            samhemelryk Sam Hemelryk added a comment -

            Integrated now thanks Mary. Master only as there is a good chance of regressions if someone has extended canvas and then customised the login page heavily.

            Testers make sure you test all themes.

            Cheers
            Sam

            rwijaya Rossiani Wijaya added a comment -

            Hi Mary,

            Thank you for fixing this. This patch fixed most of the themes except for formal white, magazine and mymobile.

            Creating new issue to fix those themes (MDL-31230).

            Test passed.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            This is now available in the git and cvs repositories.

            Consider the responsibility of your fingerprints engraved there for future generations!

            Thanks for the work, closing, ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Jun/12