Moodle
  1. Moodle
  2. MDL-29739

Question export as Moodle XML from 1.9 and then import to Moodle 2.x does not show HTML editor

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.2, 2.2
    • Fix Version/s: 2.1.3
    • Component/s: Questions
    • Labels:
    • Testing Instructions:
      Hide

      1. Run all the unit tests in /question.

      2. Read the commit comment for the rules about how question_text format should default, so you know how this is supposed to work.
      3. Export some questions as Moodle XML.
      4. Edit the XML file to remove some format="..." attributes.
      5. Re-import that file. Make sure the correct text formats have been filled in. (Perhaps the easiest way to do this is to Re-export and diff the two XML files?)

      Show
      1. Run all the unit tests in /question. 2. Read the commit comment for the rules about how question_text format should default, so you know how this is supposed to work. 3. Export some questions as Moodle XML. 4. Edit the XML file to remove some format="..." attributes. 5. Re-import that file. Make sure the correct text formats have been filled in. (Perhaps the easiest way to do this is to Re-export and diff the two XML files?)
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      Hi,
      Importing a question from moodle V1.9 does not work well in banners of responses and feedback.
      The graphical editor TinyMCE does not appear.
      No problem V2.1.2 to V2.1.2
      Mylène

        Gliffy Diagrams

          Activity

          Hide
          Tim Hunt added a comment -

          Thanks for your bug report. Once I started digging I found a bit of a mess, which hopefully I have been able to clean up.

          Show
          Tim Hunt added a comment - Thanks for your bug report. Once I started digging I found a bit of a mess, which hopefully I have been able to clean up.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Show
          Eloy Lafuente (stronk7) added a comment - The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week. TIA and ciao
          Hide
          Aparup Banerjee added a comment -

          This has been integrated and is up for testing.

          (noted that theres changes to public api for STABLE but no regressions seen within our codebase / contrib(thx Eloy) )

          Show
          Aparup Banerjee added a comment - This has been integrated and is up for testing. (noted that theres changes to public api for STABLE but no regressions seen within our codebase / contrib(thx Eloy) )
          Hide
          Rossiani Wijaya added a comment -

          This is working great. Thanks

          Test passed.

          Show
          Rossiani Wijaya added a comment - This is working great. Thanks Test passed.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Yes, you got this finally upstream, just in time for Moodle 2.2beta. Congrats and thanks!

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Yes, you got this finally upstream, just in time for Moodle 2.2beta. Congrats and thanks! Ciao

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: