Moodle
  1. Moodle
  2. MDL-29743

Clicking "Finish Attempt" in a quiz with some browsers does not properly save answers

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.5, 2.1.2, 2.2
    • Fix Version/s: 2.0.6, 2.1.3
    • Component/s: Quiz
    • Labels:
    • Database:
      PostgreSQL
    • Testing Instructions:

      Create a quiz with several questions.
      Take the quiz as a student.
      Enter an answer to a question.
      Click the "Finish Attempt" link on Quiz Navigation.
      On the Summary of Attempt page the question may be listed as "Not Answered."
      If you go back to the question your answer will be not be there.

      If your answer is successfully saved and you go back to edit your answer, your edit may not be saved if you click "Finish Attempt." However, in this scenario the Summary of Attempt will indicate that the question has been answered.

      Show
      Create a quiz with several questions. Take the quiz as a student. Enter an answer to a question. Click the "Finish Attempt" link on Quiz Navigation. On the Summary of Attempt page the question may be listed as "Not Answered." If you go back to the question your answer will be not be there. If your answer is successfully saved and you go back to edit your answer, your edit may not be saved if you click "Finish Attempt." However, in this scenario the Summary of Attempt will indicate that the question has been answered.
    • Workaround:

      It is possible to prevent this issue by clicking the Next link at the bottom of each quiz page throughout the quiz taking process.

      Show
      It is possible to prevent this issue by clicking the Next link at the bottom of each quiz page throughout the quiz taking process.
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:
    • Rank:
      19260

      Description

      Users taking a quiz, that click "Finish Attempt" instead of the "Next" button may not have their answers saved. We have seen the problem occur in Chrome, Safari, and Respondus LockDown Browser in Windows and Mac OSes. It appears to be browser specific, but not consistent. An answer may not be saved 4 times in a row and then saved on the 5th attempt. It has occurred with multiple question types, and when displaying all questions on a page or a single question per page.

        Activity

        Tim Hunt added a comment -

        Can anyone reproduce this? I have never seen it.

        Also, I am pretty sure this problem does not occur in Moodle 2.1+

        Jimmy Short added a comment -

        Hi Tim,

        We have experienced the same issue with Moodle 2.1 installed. We are able to consistently replicate the problem with Google Chrome.

        Jimmy Short added a comment -

        I should have been more specific. We have 2.1.2 on one of our development servers and we are seeing the same issue.

        Jimmy Short added a comment -

        Unfortunately we are still experiencing this issue. We are working on moving to Moodle 2.1, but have seen the same problem occur on our 2.1 development server.

        I submitted a ticket with Respondus, since our students primarily take quizzes through LockDown Browser. I've included their comments below in case it might be of some help. If this is not a widely reported issue with Moodle 2.0.x or 2.1, are their any other server side or configuration issues in our environment that could cause the Quiz Navigation widget not to work properly in some browsers or in some situations?

        Thanks,
        Jimmy

        ----Original Message----
        From: Bob Boufford esupport@respondus.com
        Sent: Monday, November 07, 2011 10:15 AM
        To: Short, Jimmy
        Subject: PRB-255214: LockDown Browser Fix for Moodle 2.x

        Hi Jimmy,

        Thanks for the access. As you have identified, it's an issue with Moodle and the Quiz Navigation widget that has the "Finish Attempt..." link. I was able to duplicate the problem in a Macintosh OS X 10.07 Lion with both Safari 5.1 and the latest Google Chrome for Macintosh for the "Answer Not Saving Test - No LDB". However, with the "Pharmacy Sample Quiz - no LDB" I was usually successful in saving the answers.

        I should note that "WebKit" is the core engine for Safari, Google Chrome, other desktop browsers and some mobile browsers such as the experimental browser in current Amazon Kindles. Any issues that appear in Safari-Macintosh will likely appear in in other "WebKit" browsers such as Google Chrome for both Macintosh and Windows.

        For the quizzes that required LockDown Browser, the extra option appeared for students to "Submit" the answer for each question as seen in many other LMSs such as Blackboard Vista/CE and Blackboard Learn.

        As this is a Moodle issue with WebKit based browsers, the issue will continue to appear in LockDown Browser - Macintosh. We did notice in our testing that the problem only occurs when clicking the "Finish attempt..." link but does not occur when using the "Next" button in all the quizzes.

        We recommend until the Moodle Developers can resolve the issue, is to encourage students to not click on "Finish attempt..." and to always use the "Submit" button when available to save individual answers to the server and the "Next" buttons to navigate to the next question or section.

        Hope this helps...

        Cheers,

        Bob
        ---------------

        Bob Boufford

        Technical Support Services

        Respondus, Inc.

        Ticket Details
        ===================
        Ticket ID: PRB-255214
        Department: Technical Support
        Priority: Low
        Status: Open

        Brandon M. Browning added a comment -

        I think the problem can be solved by changing e.preventDefault(e) to e.preventDefault() in mod/quiz/modules.js. That would be on line 155 in the 2.0.5+ code and line 173 in the 2.1.2+ code.

        Tim Hunt added a comment -

        Ah, that sounds plausible. Good detective work.

        Tim Hunt added a comment -

        Thanks for working that out Brandon. Who would have thought a one-character typo (that comes from when this code was converted from YUI2) could have that effect. I had to go and read the code in lib/yui/3.4.1/build/event-base/event-base.js to work out what was going on.

        I did a quick grep of the whole code-base (68 occurrences of preventDefault outside of third-party libraries) and this is the only place this sort of typo occurs.

        Eloy Lafuente (stronk7) added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        PS: Note this is the last message of this type that you will receive along the whole November month, because we are running continuous integration this weeks while QA tests for release of Moodle 2.2 (Dec 1st) are being performed.

        Eloy Lafuente (stronk7) added a comment -

        Nice one, well spotted! Integrated.

        Adrian Greeve added a comment -

        Tested and working.

        Eloy Lafuente (stronk7) added a comment -

        U P S T R E A M I Z E D !

        Thanks! Closing...


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: