Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29785

Upgrade TinyMCE to the latest version (3.4.6) and enable it for iPad/iPhone with iOS 5

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.2
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
      None
    • Testing Instructions:

      1/ standard TinyMCE testing required - all supported browsers in supported operating systems, concentrate on our custom plugins
      2/ try in iPad+iPhone using iOS 4 and 5 (I have tested it only in the latest iOS simulator)

      Show
      1/ standard TinyMCE testing required - all supported browsers in supported operating systems, concentrate on our custom plugins 2/ try in iPad+iPhone using iOS 4 and 5 (I have tested it only in the latest iOS simulator)
    • Affected Branches:
      MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w41_MDL-29785_m22_tinymce

      Description

      the demo site at http://www.tinymce.com/tryit/full.php works fine with my first gen iPad....

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda created issue -
              skodak Petr Skoda made changes -
              Field Original Value New Value
              Fix Version/s DEV backlog [ 10464 ]
              Priority Minor [ 4 ] Major [ 3 ]
              Assignee moodle.com [ moodle.com ] Petr Škoda (skodak) [ skodak ]
              skodak Petr Skoda made changes -
              Status Open [ 1 ] Development in progress [ 3 ]
              skodak Petr Skoda added a comment -

              it looks like tinymce 3.4.7 is coming this month - some FF7 and IE fixing there...

              skodak Petr Skoda made changes -
              Status Development in progress [ 3 ] Waiting for integration review [ 10010 ]
              Pull Master Diff URL https://github.com/skodak/moodle/compare/master...w41_MDL-29785_m22_tinymce
              Pull Master Branch w41_MDL-29785_m22_tinymce
              Pull from Repository git://github.com/skodak/moodle.git
              Fix Version/s 2.2 [ 10656 ]
              Fix Version/s DEV backlog [ 10464 ]
              Testing Instructions 1/ standard TinyMCE testing required - all supported browsers in supported operating systems, concentrate on our custom plugins
              2/ try in iPad+iPhone using iOS 4 and 5 (I have tested it only in the latest iOS simulator)
              skodak Petr Skoda added a comment -

              this is a candidate for backporting into STABLE if everything works for a week at least

              skodak Petr Skoda made changes -
              Summary import latest TinyMCE and enable it for iPad with iOS 5 import latest TinyMCE and enable it for iPad/iPhone with iOS 5
              stronk7 Eloy Lafuente (stronk7) made changes -
              Currently in integration Yes
              stronk7 Eloy Lafuente (stronk7) made changes -
              Summary import latest TinyMCE and enable it for iPad/iPhone with iOS 5 Upgrade TinyMCE to the latest version (3.4.6) and enable it for iPad/iPhone with iOS 5
              stronk7 Eloy Lafuente (stronk7) made changes -
              Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
              Integrator stronk7
              stronk7 Eloy Lafuente (stronk7) made changes -
              Link This issue has been marked as being related by MDL-29361 [ MDL-29361 ]
              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated, thanks.

              Sending reminder to David (email) about the new version in case he has to generate the lang packs to be offered to translators.

              Ciao

              stronk7 Eloy Lafuente (stronk7) made changes -
              Status Integration review in progress [ 10004 ] Waiting for testing [ 10005 ]
              samhemelryk Sam Hemelryk made changes -
              Status Waiting for testing [ 10005 ] Testing in progress [ 10011 ]
              Tester samhemelryk
              samhemelryk Sam Hemelryk added a comment -

              Failing this presently, it appears to work fine in ALL browsers except IE 7 and IE 8.
              On both of those versions of IE none of the Tiny MCE popups work, all result in the following error:

              Line: 361
              Error: 'undefined' is null or not an object

              I've never looked to TinyMCE's JS before an all I could gather from the IE debugger was that the file in question is editor_plugin_src.js

              Cheers
              Sam

              samhemelryk Sam Hemelryk made changes -
              Status Testing in progress [ 10011 ] Problem during testing [ 10007 ]
              skodak Petr Skoda added a comment -

              diagnosing, thanks

              korpelainen Mauno Korpelainen added a comment -

              I tested Petr's package both with the moodle 2.2dev code and also with older moodle 2.0 and moodle 2.1 (changed $plugin->requires = ... and I did not find any problems - tested in Debian Lenny/Squeeze server + local XP + Windows Vista + Windows 7 and all the main browsers.

              In the past (2 years ago) some versions of IE8(beta/RC1) used to have problems with popups caused by improperly registered dll files ( see for example old MDL-18645 ) so is it possible that Sam has such version of PC/IE8 that has not been upgraded for years???

              Debugging scripts with my IE8s or even IE9s in different modes (F12 - Script - Start debugging) did not give any errors at all...

              skodak Petr Skoda added a comment -

              this is strange, it works fine for me in both IE7 and IE8, I tried debug off and on, theme caching, different language - popups work fine for me in Windows XP with all updates.

              skodak Petr Skoda added a comment -

              Sam: did you try http://www.tinymce.com/tryit/full.php and older moodle versions?

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Just to confirm I've tested this under iOS 5 (iPad) and formatting, adding image from repo, emoticons... seems to be working perfectly. Although I can imagine it will look really small in an iPhone, given it was really small in the iPad.

              samhemelryk Sam Hemelryk added a comment -

              Hi fella's,

              I am still experiencing this issue - I am also experiencing the issue on the tinymce site you mentioned Petr.
              I am using IE8 on Windows Vista with everything up to date. The only upgrade I havn't applied is the upgrade to IE9 (I wanted to hang onto 8 for testing).
              Out of curiosity on that same machine I installed IE tester and interestingly enough everything worked perfectly in that, so it is just native IE that is affected.

              If everyone else can confirm it works for them in native IE8 then lets just pass this (hehe I'd just pass this anyway actually I never cared for IE)

              Cheers
              Sam

              korpelainen Mauno Korpelainen added a comment -

              Sam,

              did you read my comments and test those tips how to cure your PC in MDL-18645

              I am 99.9% sure that your problem is caused by improperly registered or damaged dll files in that PC - not moodle or code of moodle. You can also take a look at

              http://support.microsoft.com/default.aspx?scid=kb;en-us;Q281679

              korpelainen Mauno Korpelainen added a comment -

              Note that you need to type in MDL-18645 commands like

              regsvr32 actxprxy.dll

              in command prompt as administrator or Vista won't allow the registration change.

              So when you run from start menu – programs – accessories – command prompt , use mouse right click and
              Run as administrator (or use 'Run ...' as administrator) to get it done properly.

              korpelainen Mauno Korpelainen added a comment -

              And there is a 0.1% propability left that behaviour of IE8 or IE7 is caused by settings like http://support.microsoft.com/kb/175775

              Anyway - I did test yesterday about 10 different IE PCs (XP/Vista/Windows7) at work and at home and they all worked OK with tinymce 3.4.6

              korpelainen Mauno Korpelainen added a comment -

              Finally some reasons why dll files of PC can be missing/improperly registered/faulty even in a fresh install of IE8:

              http://www.computerhope.com/issues/ch000749.htm

              stronk7 Eloy Lafuente (stronk7) added a comment -

              I'm pretty sure Mauno's 10 different PCs above are:

              • 1-2 at work
              • 8-9 at home

              Geeeeeek! Thanks!

              PS: I've requested people @ HQ chat to perform some quick runs to have a bit bigger confirmation.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              IE7 + XP: tested both @ http://www.tinymce.com/tryit/full.php and QA site, seems ok.

              korpelainen Mauno Korpelainen added a comment -

              Hehe

              I do have actually 2 Windows7 PCs, 1 Windows7 laptop, 1 Vista PC, 1 XP PC, 1 XP laptop, 1 Windows2000 PC and even 1 Windows95 laptop at home but I only tested 5 of these at home. At work most of the classes are using similar PCs (about 60 clones) and there the tseting route goes from classes to teachers room and 2 PCs there...

              Easy to guess why I don't have any money left to buy those iTools just for testing moodle

              stronk7 Eloy Lafuente (stronk7) added a comment - - edited

              Way too many windows in your life, man. Open the doors to some fruity stuff!

              stronk7 Eloy Lafuente (stronk7) made changes -
              Status Problem during testing [ 10007 ] Integration review in progress [ 10004 ]
              stronk7 Eloy Lafuente (stronk7) made changes -
              Status Integration review in progress [ 10004 ] Waiting for testing [ 10005 ]
              stronk7 Eloy Lafuente (stronk7) made changes -
              Status Waiting for testing [ 10005 ] Testing in progress [ 10011 ]
              stronk7 Eloy Lafuente (stronk7) added a comment -

              Hi Sam, I'm passing this finally, based on feedback from Petr, Mauno and me.

              If you could confirm that there was some problem in your end, perfect, because this is planned to be backported soon to 21_STABLE.

              So, passing and rolling weeklies... thanks all. Ciao

              stronk7 Eloy Lafuente (stronk7) made changes -
              Status Testing in progress [ 10011 ] Tested [ 10006 ]
              stronk7 Eloy Lafuente (stronk7) added a comment -

              Many thanks for all the hard work. This is now part of Moodle, your favorite LMS.

              Closing as fixed, ciao

              stronk7 Eloy Lafuente (stronk7) made changes -
              Status Tested [ 10006 ] Closed [ 6 ]
              Resolution Fixed [ 1 ]
              Currently in integration Yes
              Integration date 19/Oct/11
              samhemelryk Sam Hemelryk added a comment -

              Hi again,

              For sure it is just my Windows installation.
              The registering of DLL's suggested by the knowledge base article led me to find that one of the DLL's could not be re-registered (Shdocvw.dll).
              A quick search points to registry problems. Hehe something I'm not concerned enough about to try to solve. Once I am in a required position I will just reinstall Windows.

              Thanks to everyone for testing this as well.

              Cheers
              Sam

              salvetore Michael de Raadt made changes -
              Link This issue is duplicated by MDL-29726 [ MDL-29726 ]
              salvetore Michael de Raadt made changes -
              Link This issue will help resolve MDL-30357 [ MDL-30357 ]

                People

                • Votes:
                  1 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    5/Dec/11