Moodle
  1. Moodle
  2. MDL-29790

Upgrading from 1.9.7 to 2.0.5 and running into DDL SQL Execution Error mod_feedback

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.5
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
      None
    • Environment:
      CentOS Linux I believe - hosted through VPS Wired Tree
    • Database:
      MySQL
    • URL:
      vandammeacademyonline.com
    • Affected Branches:
      MOODLE_20_STABLE
    • Rank:
      19303

      Description

      I found other instances of this problem on the tracker but didn't give a real solution. Only to reinstall as a fresh new copy with a brand new database. Is this possible to do and then import your past database and work properly? If so please let me know because starting with a brand new database is not an option.

      Here's a look at what the debugger told me in the install:

      Debug info: Table 'mdl_feedback' already exists
      CREATE TABLE mdl_feedback (
      id BIGINT(10) unsigned NOT NULL auto_increment,
      course BIGINT(10) unsigned NOT NULL DEFAULT 0,
      name VARCHAR(255) NOT NULL DEFAULT '',
      intro TEXT NOT NULL,
      introformat SMALLINT(4) unsigned NOT NULL DEFAULT 0,
      anonymous TINYINT(1) unsigned NOT NULL DEFAULT 1,
      email_notification TINYINT(1) unsigned NOT NULL DEFAULT 1,
      multiple_submit TINYINT(1) unsigned NOT NULL DEFAULT 1,
      autonumbering TINYINT(1) unsigned NOT NULL DEFAULT 1,
      site_after_submit VARCHAR(255) NOT NULL DEFAULT '',
      page_after_submit TEXT NOT NULL,
      page_after_submitformat TINYINT(2) unsigned NOT NULL DEFAULT 0,
      publish_stats TINYINT(1) unsigned NOT NULL DEFAULT 0,
      timeopen BIGINT(10) unsigned NOT NULL DEFAULT 0,
      timeclose BIGINT(10) unsigned NOT NULL DEFAULT 0,
      timemodified BIGINT(10) unsigned NOT NULL DEFAULT 0,
      completionsubmit TINYINT(1) NOT NULL DEFAULT 0,
      CONSTRAINT PRIMARY KEY (id)
      ) ENGINE = MyISAM
      Stack trace:

      line 397 of /lib/dml/moodle_database.php: ddl_change_structure_exception thrown
      line 669 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
      line 88 of /lib/ddl/database_manager.php: call to mysqli_native_moodle_database->change_database_structure()
      line 75 of /lib/ddl/database_manager.php: call to database_manager->execute_sql()
      line 456 of /lib/ddl/database_manager.php: call to database_manager->execute_sql_arr()
      line 408 of /lib/ddl/database_manager.php: call to database_manager->install_from_xmldb_structure()
      line 499 of /lib/upgradelib.php: call to database_manager->install_from_xmldb_file()
      line 271 of /lib/upgradelib.php: call to upgrade_plugins_modules()
      line 1427 of /lib/upgradelib.php: call to upgrade_plugins()
      line 311 of /admin/index.php: call to upgrade_noncore()

      Any help would be greatly appreciated!
      Matt

        Activity

        Matthew Mintun added a comment -

        No body? Can someone please help me with this error, I need to get this site up ASAP.

        Petr Škoda added a comment -

        Hello,
        this is most probably caused by invalid directories in your $CFG->dirroot directory, upload a fresh install keeping only the config.php. In any case it might be better to install latest 2.1.x

        Please use moodle.org forums for general support, thanks.

        Petr


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: