Moodle
  1. Moodle
  2. MDL-29842

Lists doesn't appear in a label on the front page of the site

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.2, 2.2
    • Fix Version/s: None
    • Labels:
      None
    • Database:
      MySQL
    • Testing Instructions:

      As an admin : go to "Frontpage settings", and activate "Include a topic section"
      Go to the frontpage, and turn editing on.
      Add a "Label", containing a list (order or unorder), for example (HTML code):

      <p>Some simple text :</p>
      <ul>
      <li>first item</li>
      <li>second item</li>
      <li>item 3</li>
      <li>item 4</li>
      </ul>
      <p>Still simple texte.</p>

      You can see that all is well presented in editor mode
      Save the label.
      You don't see the dots of the list

      Tested today on my 2.1.2+ (latest) site, on demo.moodle.net (2.1.x) and on http://qa.moodle.net/ (2.2dev). Not tested in previous versions.
      On my site, even with "Standard" theme, the problem is the same.

      Show
      As an admin : go to "Frontpage settings", and activate "Include a topic section" Go to the frontpage, and turn editing on. Add a "Label", containing a list (order or unorder), for example (HTML code): <p>Some simple text :</p> <ul> <li>first item</li> <li>second item</li> <li>item 3</li> <li>item 4</li> </ul> <p>Still simple texte.</p> You can see that all is well presented in editor mode Save the label. You don't see the dots of the list Tested today on my 2.1.2+ (latest) site, on demo.moodle.net (2.1.x) and on http://qa.moodle.net/ (2.2dev). Not tested in previous versions. On my site, even with "Standard" theme, the problem is the same.
    • Workaround:

      Don't use lists !!!
      But it's the simpliest element...

      Show
      Don't use lists !!! But it's the simpliest element...
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Rank:
      19367

      Description

      On the frontage, if you have allowed a topic section, and insert a "Label", you can't use lists (order or not) in the labels, because they're not visible

        Activity

        Dan Poltawski added a comment -

        Hi,

        I can't reproduce this - is it a specific theme?

        Séverin Terrier added a comment -

        Strange that you can't reproduce that...

        As i already said, the problem is visible on several sites, including moodle.org demo an qa sites, and with several themes (including standard).

        Are you sure that you try to "Add a label" ? Because it's OK in "Summary of site" !
        But copy "Summary of site"'s content in a new label, and you'll see that it's not ok

        Séverin Terrier added a comment -

        Tried again just now, and the problem is still the same (on moodle.org demo an qa sites) !

        Séverin Terrier added a comment -

        This bug is no longer present in recent versions of Moodle (2.1.x and 2.2.x). This can be closed !
        It seems that i can't do that myself (or haven't find how)...

        Séverin Terrier added a comment -

        This can be closed (corrected in recent versions) !

        Helen Foster added a comment -

        Thanks for your feedback Severin. Closing as suggested.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: