Moodle
  1. Moodle
  2. MDL-29851

assignment submissions.php throws db error when using visible groups mode

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.1.1
    • Fix Version/s: None
    • Component/s: Assignment (2.2)
    • Labels:
      None
    • Environment:
      Centos 5.x x86_64, Postgresql 8.4, php 5.3.x, apache 2.2
    • Database:
      PostgreSQL
    • Testing Instructions:

      create an assignment in the visible groups mode.
      let students submit their assignments.
      open the submitted assignments

      Show
      create an assignment in the visible groups mode. let students submit their assignments. open the submitted assignments
    • Affected Branches:
      MOODLE_21_STABLE
    • Rank:
      19375

      Description

      When you want to see the submissions of an assignment using visible groups mode and you click on the "View X submitted assignments" link you get an 'Error reading from database' message:

      e.g.

      Debug info: ERROR: column "status" does not exist at character 467
      SELECT u.id,u.picture,u.firstname,u.lastname,u.imagealt,u.email,
      s.id AS submissionid, s.grade, s.submissioncomment,
      s.timemodified, s.timemarked FROM mdl_user u LEFT JOIN mdl_assignment_submissions s ON u.id = s.userid
      AND s.assignment = 1329 WHERE u.id IN (11399,395,9660,3125,2675,13744,5234,2144,2510,12783,13603,4836,10865,2522,2567,3050,6448,13717,6396,2460,14207,2122) ORDER BY status ASC, lastname ASC
      [array (
      )]
      Stack trace:
      line 394 of /lib/dml/moodle_database.php: dml_read_exception thrown
      line 232 of /lib/dml/pgsql_native_moodle_database.php: call to moodle_database->query_end()
      line 678 of /lib/dml/pgsql_native_moodle_database.php: call to pgsql_native_moodle_database->query_end()
      line 1321 of /mod/assignment/lib.php: call to pgsql_native_moodle_database->get_records_sql()
      line 645 of /mod/assignment/lib.php: call to assignment_base->display_submissions()
      line 369 of /mod/assignment/type/upload/assignment.class.php: call to assignment_base->submissions()
      line 57 of /mod/assignment/submissions.php: call to assignment_upload->submissions()

        Issue Links

          Activity

          Eloy Lafuente (stronk7) added a comment -

          Closing this as duplicate of MDL-29529


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: