Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29906

Use of deprecated helpbutton in quiz statistics report.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.2
    • Fix Version/s: 2.1.3
    • Component/s: Quiz
    • Labels:
    • Environment:
      2.1.2+ (Build: 20111012), PHP Version 5.3.6, MySQL 5.1.57.
    • Database:
      MySQL
    • Testing Instructions:

      1. Create a quiz with three questions.
      2. Attempt this quiz as three different students, as the first two students, get questions 1 and 2 right, and question 3 wrong.
      3. As the third student get questions 1 and 2 wrong, and 3 right.
      4. As teacher, go to the quiz statistics report. You should see a message saying "Negative covariance of grade with total attempt grade" with a help icon in the Effective weight column for question 3.

      Check that the help icon works, and that there is no notice.

      Show
      1. Create a quiz with three questions. 2. Attempt this quiz as three different students, as the first two students, get questions 1 and 2 right, and question 3 wrong. 3. As the third student get questions 1 and 2 wrong, and 3 right. 4. As teacher, go to the quiz statistics report. You should see a message saying "Negative covariance of grade with total attempt grade" with a help icon in the Effective weight column for question 3. Check that the help icon works, and that there is no notice.
    • Affected Branches:
      MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Pull Master Branch:

      Description

      When I go into statistics for a quiz, I am seeing a lot of error messages (see attachment). It appears that maybe some old code (deprecated) is still being used.

      I don't detect any problems with the statistics, I just thought that I would report this problem.

        Gliffy Diagrams

          Attachments

            Activity

            samhemelryk Sam Hemelryk added a comment -

            Thanks Tim - this has been integrated now

            ankit_frenz Ankit Agarwal added a comment -

            Hi,
            This Works perfectly.
            Thanks

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Done, your delicious hacks have been sent upstream, many thanks!

            Closing as fixed, ciao

            rjerz Rick Jerz added a comment -

            It's Rick, and I made the original post. To be quite honest, when I made my post I thought that no one would care to fix this (minor) issue. You folks have shown me once again that you are truly interested in improving problems. It is remarkable that you got to this so quickly.

            Please continue keeping up the good work. Very impressive!

            timhunt Tim Hunt added a comment -

            To be honest, that was just luck. The issue hit my inbox at just the moment I had 5 minutes to spare, and because the issue is so trivial, the fix was too. Sadly, there are many more serious issues waiting for me to have time.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  28/Nov/11