Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29984

invalid use of undefined $today in enrol/manual/lib.php

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.2, 2.2
    • Fix Version/s: 2.1.3
    • Component/s: Enrolments
    • Labels:
      None
    • Testing Instructions:
      Hide

      1/ somehow set course start date to 0
      2/ go to enrolled users and try to manually enrol user
      3/ you should see only today (no course start date) in advanced options
      4/ no warnings or errors

      Show
      1/ somehow set course start date to 0 2/ go to enrolled users and try to manually enrol user 3/ you should see only today (no course start date) in advanced options 4/ no warnings or errors
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w43_MDL-29984_m22_enroltoday

      Description

      This was reported by Rossiani in MDL-29688, I did not find any new issue for it...

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              Hide
              skodak Petr Skoda added a comment -

              In order to replicate this you need to somehow set course start date to 0, I do not know how to do that via moodle UI...

              Show
              skodak Petr Skoda added a comment - In order to replicate this you need to somehow set course start date to 0, I do not know how to do that via moodle UI...
              Hide
              nebgor Aparup Banerjee added a comment -

              thanks , this has been integrated - this likely needs a developer's touch (DB) to test.

              Show
              nebgor Aparup Banerjee added a comment - thanks , this has been integrated - this likely needs a developer's touch (DB) to test.
              Hide
              rwijaya Rossiani Wijaya added a comment -

              Just some note on how to reproduce this issue: set external db setting to create new course and run cron to execute enrol/database/cli/sync.php script. Once it created, access the course on ui and try to enrolled user.

              Petr's patch fixed the issue and its all good now. Thanks.

              Test passed.

              Show
              rwijaya Rossiani Wijaya added a comment - Just some note on how to reproduce this issue: set external db setting to create new course and run cron to execute enrol/database/cli/sync.php script. Once it created, access the course on ui and try to enrolled user. Petr's patch fixed the issue and its all good now. Thanks. Test passed.
              Hide
              stronk7 Eloy Lafuente (stronk7) added a comment -

              And this has been sent upstream (already available @ git and cvs repos). Many, many thanks!

              Closing as fixed, ciao

              Show
              stronk7 Eloy Lafuente (stronk7) added a comment - And this has been sent upstream (already available @ git and cvs repos). Many, many thanks! Closing as fixed, ciao

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    28/Nov/11