Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-29995

Mark all the legacy filters support as deprecated for 2.2

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2
    • Component/s: Filters
    • Labels:
    • Testing Instructions:
      Hide

      No testing needed, just documentation and some comments and phpdocs in code, the only post-integration task is to link from the release notes to the new filter/upgrade.txt file.

      Show
      No testing needed, just documentation and some comments and phpdocs in code, the only post-integration task is to link from the release notes to the new filter/upgrade.txt file.
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      Once we have moved all core filters to the new proper ones, it's time to mark all places in code relating to legacy filters and legacy locations as deprecated. The (long) plan is to:

      • In 2.2 they are in deprecated status so will continue working (this issue).
      • In 2.3 they won't work anymore, all deprecated filters and locations will be ignored.
      • In 2.4 (or perhaps 2.3 too) some filters stuff will be moved to use proper component names instead of current, imperfect, 'filter/xxxx'.

      Back to this issue, we'll be adding comments along codebase about the deprecation and commenting in the release notes.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Votes:
                  1 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    5/Dec/11