Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30006

Force reviewers to actually select a grade in assessment forms instead of having one pre-selected

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.5, 2.1.2
    • Fix Version/s: 2.0.6, 2.1.3
    • Component/s: Workshop
    • Labels:
      None
    • Database:
      Any
    • Testing Instructions:

      Note: I already tested on 2.0 before submitting to integration. Please test 2.1 primarily. Thanks, David.

      A1. Prepare a workshop using the Accumulative grading strategy
      A2. Edit the grading form and define at least two aspects - one using a numerical grade, one using a scale
      A3. As a student, make a submission
      A4. As a teacher, open the submission and go and assess it
      A5. TEST: make sure no grade or scale item is pre-filled when opening the form
      A6. TEST: try to submit the form without choosing a grade - make sure the validation fails with a message displayed
      A7. TEST: make sure that after selecting all required grades, the form can be saved
      A8. TEST: make sure you can re-assess the form with no regressions

      B1. Edit the workshop setting and switch the grading strategy to the Number of errors (or create a new workshop, up to you)
      B2. Edit the grading form and define some assertions
      B3. As a student, make a submission (no need if re-using the workshop)
      B4. As a teacher, open the submission and go and assess it
      B5. TEST: make sure no assertion answer is pre-filled when opening the form
      B6. TEST: try to submit the form without answering some assertion - make sure the validation fails with a message displayed
      B7. TEST: make sure that after answering all required assertions, the form can be saved
      B8. TEST: make sure you can re-assess the form with no regressions

      Show
      Note: I already tested on 2.0 before submitting to integration. Please test 2.1 primarily. Thanks, David. A1. Prepare a workshop using the Accumulative grading strategy A2. Edit the grading form and define at least two aspects - one using a numerical grade, one using a scale A3. As a student, make a submission A4. As a teacher, open the submission and go and assess it A5. TEST: make sure no grade or scale item is pre-filled when opening the form A6. TEST: try to submit the form without choosing a grade - make sure the validation fails with a message displayed A7. TEST: make sure that after selecting all required grades, the form can be saved A8. TEST: make sure you can re-assess the form with no regressions B1. Edit the workshop setting and switch the grading strategy to the Number of errors (or create a new workshop, up to you) B2. Edit the grading form and define some assertions B3. As a student, make a submission (no need if re-using the workshop) B4. As a teacher, open the submission and go and assess it B5. TEST: make sure no assertion answer is pre-filled when opening the form B6. TEST: try to submit the form without answering some assertion - make sure the validation fails with a message displayed B7. TEST: make sure that after answering all required assertions, the form can be saved B8. TEST: make sure you can re-assess the form with no regressions
    • Affected Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-30006-workshop-grades

      Description

      Reported by Jori Mäntysalo at http://moodle.org/mod/forum/discuss.php?d=187559 :
      Some students have written good evaluation, but forgot to change points given. That's because form has some default value, for example "10". Is it possible to remove default values and force students to really select some value? Something like "<give points>" as first value on dropdown box.

        Gliffy Diagrams

          Activity

          vrrandall Vernellia Randall added a comment -

          This is more than a minor problem if you use the numerical evaluation for grading.

          mudrd8mz David Mudrak added a comment -

          Submitting for integration.

          There are two patches, one fixes the Accumulative grading and the second fixes the Number of errors grading strategy. The Rubric strategy does not need to be fixed as it works well there.

          Both assessment forms should now open blank and each dimension requires explicit grader's input. An attempt to save the form without the explicit assessment is supposed to fail, displaying the validation warning.

          mudrd8mz David Mudrak added a comment -

          Increasing priority to major.

          samhemelryk Sam Hemelryk added a comment -

          Thanks David - this has been integrated now

          abgreeve Adrian Greeve added a comment -

          Tested with version 2.1 Stable. Looked at the difference patches for the other versions. All are identical.

          stronk7 Eloy Lafuente (stronk7) added a comment -

          And this has been sent upstream (already available @ git and cvs repos). Many, many thanks!

          Closing as fixed, ciao


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                28/Nov/11