Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30028

Preference setting is broken in scorm report

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2, 2.3
    • Fix Version/s: 2.2.1
    • Component/s: SCORM
    • Labels:
    • Testing Instructions:

      Enter SCORM reports page,
      set page pref to 'user with no attempts only' and save preference.
      Then click on 'surname' to reorder user by their surname.

      Check to make sure page pref stays as previously set.

      Check both "basic" and "interactions" report

      Show
      Enter SCORM reports page, set page pref to 'user with no attempts only' and save preference. Then click on 'surname' to reorder user by their surname. Check to make sure page pref stays as previously set. Check both "basic" and "interactions" report
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull Master Branch:
      master_MDL-30028

      Description

      The issue is discovered while testing for MDL-30009.

      To reproduce:
      on report page, set show to 'user with no attempts only' and save preference. Then click on 'surname' to reorder user by their surname. The report page is refresh by showing list of user wit attempts and show selection is set back to 'all users'

        Gliffy Diagrams

          Issue Links

            Activity

            ankit_frenz Ankit Agarwal added a comment -

            Just to note this effects both interaction report and basic report in 2.2
            Thanks

            danmarsden Dan Marsden added a comment -

            NOTE TO INTEGRATOR - Master only.

            samhemelryk Sam Hemelryk added a comment -

            Hi Dan, just checking but by the looks of it this is required in MOODLE_22_STABLE and master. Is that correct?

            danmarsden Dan Marsden added a comment -

            whoops - good point 22_stable as well please! - thanks Sam!

            nebgor Aparup Banerjee added a comment -

            Thanks all, integrated into 2.2 and master.

            ankit_frenz Ankit Agarwal added a comment -

            Works Great, But found another issue, Follow the below process to reciprocate:-

            • Goto scorm>report>basic
            • Select show all users and save
            • From the surname table select a Letter such that no user has a surname starting with that letter
            • This will show something like
              0 results (0 users)
              Nothing to report
            • Which is correct but the problem is, you end up in a locked state, the top selection bar is now not present so there is no way to change the selections.

            Will create a issue for that
            Thanks

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Yes, you did it!

            Now your code is part of the best weeklies released ever, many thanks!

            Closing, ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  9/Jan/12