Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30153

"NOTICE: Wiki-like formatting has been removed from Moodle" when editing multiple choice in cloze question

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.1.1
    • Fix Version/s: None
    • Component/s: Questions
    • Labels:
    • Database:
      MySQL
    • Testing Instructions:

      Create a cloze question
      write a Multiple choice question inside cloze question
      the error appearse when previewing the question

      Show
      Create a cloze question write a Multiple choice question inside cloze question the error appearse when previewing the question
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      When writing a multiple choice question in a cloze question, the following error appears:

      NOTICE: Wiki-like formatting has been removed from Moodle. You should not be seeing this message as all texts should have been converted to Markdown format instead. Please post a bug report to http://moodle.org/bugs with information about where you saw this message.

        Gliffy Diagrams

          Attachments

            Activity

            timhunt Tim Hunt added a comment -

            I have never seen this. Are you using the HTML editor or not?

            ppichet Pierre Pichet added a comment -

            I try on moodle demo 2.1.2 using Mac safari and setting developper debug with question text like
            San Francisco:

            {1:MULTICHOICE:=California#OK~Arizona#Wrong}

            San Francisco:

            {1:MULTICHOICE_V:=California#OK~Arizona#Wrong}

            San Francisco:

            {1:MULTICHOICE_H:=California#OK~Arizona#Wrong}

            and things were Ok.

            ppichet Pierre Pichet added a comment -

            However on multianwer/questiontype.php in the function qtype_multianswer_extract_question($text) {
            the
            $wrapped->questiontext['format'] = 0;
            I think it should be set to the $question->questiontext['format'] value or 1 as
            $wrapped->partiallycorrectfeedback['format'] = '1';

            although the value has been replaced by php constant.

            I remember to set it on MDL-26511 first version
            https://github.com/ppichet/moodle/commit/a6deba0ebb4ff168a4ea737bf37af118a42f462a
            question/type/multianswer/questiontype.php

            + $wrapped->questiontext['text'] = $answerregs[0];
            876
            + $wrapped->questiontext['format'] = $question->questiontext['format'] ;
            877
            + $wrapped->questiontext['itemid'] = $question->questiontext['itemid'] ;
            781 878

            I let you settle if this is the best setting.

            I am currently working on the updated version of MDL-26511

            ppichet Pierre Pichet added a comment -

            Tim,
            I retested on Moodle demo site 2,2,1 and the problem seems to be solved.
            see also the similar tests done by Joseph.
            http://moodle.org/mod/forum/discuss.php?d=194074.

            I think we can close this bug

            timhunt Tim Hunt added a comment -

            Closing, as per the last comment.

            If you can still reproduce this, please tell us how!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: