Moodle
  1. Moodle
  2. MDL-30164

missing gap between icons and text in reports using standard theme (SOLUTION INCLUDED)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.2
    • Fix Version/s: 2.0.6, 2.1.3
    • Component/s: Themes
    • Labels:
    • Rank:
      25984

      Description

      using standard theme
      and accessing the "Activity report"
      there is no gap between icons and text displayed on the right.

      See attachment for more details.

      A way to fix this, is by changing line 80 of theme/base/style/core.css
      from

       
      img.icon {height:16px;vertical-align:middle;width:16px;}
      

      to

       
      img.icon {height:16px;vertical-align:middle;width:16px;padding-right:4px;}
      

        Activity

        Michael de Raadt added a comment -

        Thanks for reporting this and providing a solution. I was able to duplicate the problem.

        I'm wondering if this change needs to be more specific to localise the effect of the change? Perhaps the change can be made to icons with tables.

        Daniele Cordella added a comment - - edited

        Ciao Michael and thanks for your intervention.
        May I ask for the reason why you didn't labeled as triaged and patch even my other two similar bugs, MDL-29830 and MDL-29778?
        Is there something I made wrong?
        May I help?
        TIA

        Mary Evans added a comment -

        Hi Daniele,

        I think the developers are so busy getting Moodle 2.2 ready for release soo that little things like this are "small fish" and as such are not so important. However, if you see ANY BUGS you can fix please do them, that will save me time. I am not sure if being triaged makes any difference, perhaps it does put it to the top of the list, but even so you can still add the patch.

        It would be great if you could fix THIS BUG but only fix it in Master then if it misses this week it should still be easy enough to cherry-pick it to the stable branches when it is integrated.

        Ciao
        Mary

        Daniele Cordella added a comment -

        Ciao Mary and thanks for your call.
        I do not think I can "send to integration" as Michael de Raadt commented in MDL-28460.
        I am not the "mantainer" of "base" theme and I do not know which process I should start in order to submit my solution. (workflow? Start peer review? I do not know what they are for and I have never used them.)
        This is why I limited my intervention to the patch written in the tracker issue.

        Is there something I should know?
        Where can I find documentation in moodledocs?

        Nevertheless, I am available to submit for integration whether...

        Ciao.

        Mary Evans added a comment - - edited

        Ah...I thought that because you had permission to assign a tracker issue to yourself, I was under the impression you could do any fixes to Moodle.

        As for protocols and such...as far as I am aware fixing this in BASE theme and fixing Formal White is the same process.

        You update your GIT HUB Moodle branches, then create a branch off master for your MDL-XXXXX, add the patch (in this case to theme/base/style/core.css) using your favourite 'Text Editor', then ADD/COMMIT/PUSH it to your GitHub and then alter the workflow to "Submit for Integration" and update the MDL PULL request info. But like I said this only needs to be added to Master as it is not a bug but an improvement as such.

        When you created this did you assign it to me or was it automatic?

        Anyway...it will be interesting to find out who can do what!

        In the mean time I'll add this to my TODO list

        Cheers
        Mary

        Mary Evans added a comment -

        @Daniele
        "...dai e dai la barca ariva ai pai..."

        Daniele Cordella added a comment -

        Thanks Mary. Yesterday I was not on the web so I get your messages only now.
        Thanks for your support.

        Few question before closing:
        1. of course, the protocol is always the same but: am I allowed to submit for integration or do I have to start some different process. What does the comment from Michael mean exactly? What was I supposed to do? Peer to peer?
        2. The automatic assign is to Patrick, as fas I as remember. Michael assigned it to you.
        3. If you give me an answer to question number 1 I can submit for integration the other two pending bugs (MDL-29830 and MDL-29778).
        4. Do you feel I can push again MDL-29614 (without no extra changes respect what I already pushed) in order to really push Sam or this is not "polite"? IMHO it is a shame that fix lies untouched.

        Do you have origins in north of Italy? You have written in Venetian dialect!! 8-)

        Ciao and thanks again.

        Mary Evans added a comment -

        Hi Daniele,

        Well I am not too sure about this, but as I see it, the more that gets done the better it is for everyone, Moodle included.

        You already have certain permissions to do what you are doing with Formal White, however, you need to be aware that it is ultimately the decision of those who work at Moodle HQ, like Sam, who have the last word. Pushing amended code to your GITHUB is good, whether or not it is accepted is another matter entirely. If you do something in the wrong order, someone from HQ will advise you what you should be doing, and how to do it.

        I think the reason that Michael said about Peer Review in that particular case, is because it was a change from the normal and needed a 'closer look' before being integrated. Peer review, in this particular case, is about accepting changes which are 'improvements for the better' rather than 'changes for changes sake'. There is a subtle difference.

        As for pushing MDL-29614 as it is, will either be accepted or rejected, with or without amendments.
        My advice is, if YOU think it is right, then do it, because it is easier to apologies than it is to get permission.

        At the end of the day, you can only do what you can do. If you cannot 'assign yourself' to a tracker issue you created then so be it, you will not be able to see the other settings which allow you to 'submit for integration'. But that said, there is nothing stopping you from doing the changes and pushing them to GITHUB and then ask me to PEER REVIEW it and if OK I can submit it for integration.

        So we have the best of both worlds here. Does this sound logical?

        As far as MDL-29830 and MDL-29778 I'll add my comments there. OK?

        as for my origins - mia mama era una veneziana

        Ciao
        Mary

        Eloy Lafuente (stronk7) added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        PS: Note this is the last message of this type that you will receive along the whole November month, because we are running continuous integration this weeks while QA tests for release of Moodle 2.2 (Dec 1st) are being performed.

        Sam Hemelryk added a comment -

        Thanks Mary - this has been integrated now
        I've cherry-picked to the stable branches as well.

        Cheers
        Sam

        Sam Hemelryk added a comment -

        Tested during integration

        Eloy Lafuente (stronk7) added a comment -

        And this has landed upstream, just on time for the upcoming new releases week. Thanks for it!

        Ciao


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: