Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30167

Numerical question type gives a Warning when a unit is required, but not entered

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.2, 2.2
    • Fix Version/s: 2.1.3
    • Component/s: Questions
    • Labels:
    • Testing Instructions:

      1. Follow the steps to reproduce in the Description. Verify that after this fix, there is no Warning.

      2. Run all the unit tests in /question.

      Show
      1. Follow the steps to reproduce in the Description. Verify that after this fix, there is no Warning. 2. Run all the unit tests in /question.
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      1. Create a numerical question set to "The unit must be given, and will be graded", "the text input element", and enter some units.

      2. Preview the question. Type a response without a unit.

      3. There is a notice "Warning: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer in /fs1/www_root/icmatest/vle/question/type/numerical/questiontype.php on line 698"

        Gliffy Diagrams

          Attachments

            Activity

            stronk7 Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            PS: Note this is the last message of this type that you will receive along the whole November month, because we are running continuous integration this weeks while QA tests for release of Moodle 2.2 (Dec 1st) are being performed.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks!

            ankit_frenz Ankit Agarwal added a comment -

            All Good
            Passing
            Thanks

            stronk7 Eloy Lafuente (stronk7) added a comment -

            U P S T R E A M I Z E D !

            Thanks! Closing...


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  28/Nov/11