Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30187

mahara_host and moodle_host icons needs transparent background

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.1.2, 2.2
    • Fix Version/s: 2.3
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      • change the system theme to one where blocks have a non-white background. I used 'Anomaly'
      • Setup a Mahara MNet peer – if you're feeling lazy:
        • Enable Networking in Site administration -> Advanced features
        • Enable the MNet Auth mechanism
        • use the following DB query

          insert into mdl_mnet_host (wwwroot, name, public_key, public_key_expires, applicationid) values ('http://foo.local/mahara', 'mahara', '1234', 1234567890, 2);

        • Open Site administration -> Networking -> Peers -> mahara
        • Click services
        • Subscribe, Blank, Publish, Subscribe
      • give authenticated users permission to roam:
        • Site administration -> Users -> Permissions -> Define Roles
        • Edit 'Authenticated users'
        • Tick 'Roam to a remote application via MNet'
      • add the network servers block to the front page
      • visit the home page
      • Confirm that the icon no longer has a white background
      Show
      change the system theme to one where blocks have a non-white background. I used 'Anomaly' Setup a Mahara MNet peer – if you're feeling lazy: Enable Networking in Site administration -> Advanced features Enable the MNet Auth mechanism use the following DB query insert into mdl_mnet_host (wwwroot, name, public_key, public_key_expires, applicationid) values ('http://foo.local/mahara', 'mahara', '1234', 1234567890, 2); Open Site administration -> Networking -> Peers -> mahara Click services Subscribe, Blank, Publish, Subscribe give authenticated users permission to roam: Site administration -> Users -> Permissions -> Define Roles Edit 'Authenticated users' Tick 'Roam to a remote application via MNet' add the network servers block to the front page visit the home page Confirm that the icon no longer has a white background
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-30187-master-2

      Description

      When using a theme in which the background for blocks is non-white, any mahara host icon looks out of place because it doesn't have a transparent background.

      Affected files:

      • /pix/i/mahara_host.gif

        Gliffy Diagrams

        1. patch.txt
          0.8 kB
          Roshan Kumar
        1. mahara_host.gif
          0.3 kB
        2. mahara_host.gif
          0.4 kB
        3. mahara_host.gif
          0.3 kB

          Activity

          salvetore Michael de Raadt added a comment -

          Thanks for reporting that, Andrew.

          roshan_iiita Roshan Kumar added a comment - - edited

          mahara_host.gif is now transparent and moodle_host.gif was already transparent.

          dobedobedoh Andrew Nicols added a comment -

          Thanks Roshan,

          I'll take this and prepare it for review though it probably won't be for a few days I'm afraid.

          dobedobedoh Andrew Nicols added a comment -

          Hi Roshan,

          Thanks for providing this patch. I've just reviewed the patch and noticed that the image dimensions have changed. The image needs to be 16 pixels x 16 pixels.

          Any chance that you could adjust the image accordingly and I'll re-prepare the patch.

          Alternatively, if you're familiar with git and can publish a git branch (e.g. on github) then I can peer review it and submit it for integration.

          Thanks again!

          Andrew

          roshan_iiita Roshan Kumar added a comment -

          Updated 16x16 pixels transparent icon.

          dobedobedoh Andrew Nicols added a comment -

          Hi Roshan,

          The latest logo you've uploaded appears to be stretched. The original logo was an 8x16 logo centred on a 16x16 canvas.

          Cheers,

          Andrew

          roshan_iiita Roshan Kumar added a comment -

          The correct one

          dobedobedoh Andrew Nicols added a comment -

          Note to integrators:
          This should cherry-pick cleanly to all stable branches

          dobedobedoh Andrew Nicols added a comment -

          Thanks Roshan,

          This looks good. I'm submitting it for integration now and (hopefully) your hard work will soon be a part of Moodle.

          poltawski Dan Poltawski added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          poltawski Dan Poltawski added a comment -

          Hi,

          I've integrated this now - however I note that this doesn't fix of all of your reported issue so please ensure the issue with moode icon is not lost and this issue description/title is updated?

          dobedobedoh Andrew Nicols added a comment -

          Just confirmed, but moodle_host.gif is already transparent. Updated issue description to suit.

          andyjdavis Andrew Davis added a comment -

          Works as described.

          stronk7 Eloy Lafuente (stronk7) added a comment -

          This has been near becoming rejected, because it's not the best code you are able to produce.

          But, luckily, at the end, it has landed and has been spread to all repos out there.

          Many thanks and, don't forget it, keep improving your skills, you can!

          Closing, ciao


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                25/Jun/12