Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30192

Problem creating deleted users on restore

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Fixed
    • 2.2
    • 2.0.6, 2.1.3
    • Backup
    • MOODLE_22_STABLE
    • MOODLE_20_STABLE, MOODLE_21_STABLE
    • Hide
      • Create one course and enrol 2-3 student.
      • Create 1 forum and add some posts.
      • Go to admin/users and delete one of the users.
      • Verify that their posts continue being shown in the course
      • Make a backup of the course
      • Restore the course into ANOTHER site (so the user will need to be created).
      • TEST: No error happens and restore ends ok.
      • TEST: Go to the restored course and verify that the forums still show the posts from the deleted user.
      • TEST: Clicking on the deleted user fullname leads to "Invalid user" error. This is in fact a regression that has been addressed @ MDL-30276 but that's the output provided right now.

      That is!

      Show
      Create one course and enrol 2-3 student. Create 1 forum and add some posts. Go to admin/users and delete one of the users. Verify that their posts continue being shown in the course Make a backup of the course Restore the course into ANOTHER site (so the user will need to be created). TEST: No error happens and restore ends ok. TEST: Go to the restored course and verify that the forums still show the posts from the deleted user. TEST: Clicking on the deleted user fullname leads to "Invalid user" error. This is in fact a regression that has been addressed @ MDL-30276 but that's the output provided right now. That is!

    Description

      I have a backup that I use for testing freshly installed sites.
      The backup was originally taken in August 2010, and I have last successfully restored it in August 2011.
      Today I've tried to restore it twice and both times have got the following:

      error/unknown_context_mapping

      More information about this error

      Stack trace:
      line 637 of /backup/util/dbops/restore_dbops.class.php: restore_dbops_exception thrown
      line 869 of /backup/util/dbops/restore_dbops.class.php: call to restore_dbops::send_files_to_pool()
      line 691 of /backup/moodle2/restore_stepslib.php: call to restore_dbops::create_included_users()
      line 34 of /backup/util/plan/restore_execution_step.class.php: call to restore_create_included_users->define_execution()
      line 153 of /backup/util/plan/base_task.class.php: call to restore_execution_step->execute()
      line 148 of /backup/util/plan/base_plan.class.php: call to base_task->execute()
      line 157 of /backup/util/plan/restore_plan.class.php: call to base_plan->execute()
      line 302 of /backup/controller/restore_controller.class.php: call to restore_plan->execute()
      line 144 of /backup/util/ui/restore_ui.class.php: call to restore_controller->execute_plan()
      line 45 of /backup/restore.php: call to restore_ui->execute()
      Output buffer: Notice: Trying to get property of non-object in /backup/util/dbops/restore_dbops.class.php on line 827

      Attachments

        Issue Links

          Activity

            People

              stronk7 Eloy Lafuente (stronk7)
              samhemelryk Sam Hemelryk
              Sam Hemelryk Sam Hemelryk
              Jason Fowler Jason Fowler
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Sujith Haridasan
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                28/Nov/11