Moodle
  1. Moodle
  2. MDL-30196

The choosereadme text of SkyHigh refers to Serenity theme

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.1.2
    • Fix Version/s: 2.0.6, 2.1.3
    • Component/s: Themes
    • Labels:
    • Database:
      Any
    • Testing Instructions:

      Go to the Theme Selector
      Select Sky High theme
      At the top of the description of the theme the 'About' paragraph refers to the Serenity theme - this should refer to Sky High...

      Show
      Go to the Theme Selector Select Sky High theme At the top of the description of the theme the 'About' paragraph refers to the Serenity theme - this should refer to Sky High...
    • Workaround:

      In the skyhigh lang/en/theme_sky_high.php file edit the lines

      $string['choosereadme'] = '<div class="clearfix"><div class="theme_screenshot"><h2>Sky High</h2><img src="sky_high/pix/screenshot.png" /><h3>Theme Discussion Forum:</h3><p><a href="http://moodle.org/mod/forum/view.php?id=46">http://moodle.org/mod/forum/view.php?id=46</a></p><h3>Theme Credits</h3><p><a href="http://docs.moodle.org/en/Theme_credits">http://docs.moodle.org/en/Theme_credits</a></p><h3>Theme Documentation:</h3><p><a href="http://docs.moodle.org/en/Themes">http://docs.moodle.org/en/Themes</a></p><h3>Report a bug:</h3><p><a href="http://tracker.moodle.org">http://tracker.moodle.org</a></p></div><div class="theme_description"><h2>About</h2><p>Serenity is a fluid-width, three-column theme for Moodle 2.0.<h2>Tweaks</h2><p>This theme is built upon both Base and Canvas, two parent themes included in the Moodle core. If you want to modify this theme, we recommend that you first duplicate it then rename it before making your changes. This will prevent your customized theme from being overwritten by future Moodle upgrades, and you\'ll still have the original files if you make a mess. More information on modifying themes can be found in the <a href="http://docs.moodle.org/en/Theme">MoodleDocs</a>.</p><h2>Credits</h2>	<p>This theme was designed by Julian Ridden (julian@moodle.com.au). It was coded and is maintained by John Stabinger of NewSchool Learning (contact@newschoollearning.com). </p><h2>License</h2><p>This, and all other themes included in the Moodle core, are licensed under the <a href="http://www.gnu.org/licenses/gpl.html">GNU General Public License</a>.</div></div>';
      

      to

      $string['choosereadme'] = '<div class="clearfix"><div class="theme_screenshot"><h2>Sky High</h2><img src="sky_high/pix/screenshot.png" /><h3>Theme Discussion Forum:</h3><p><a href="http://moodle.org/mod/forum/view.php?id=46">http://moodle.org/mod/forum/view.php?id=46</a></p><h3>Theme Credits</h3><p><a href="http://docs.moodle.org/en/Theme_credits">http://docs.moodle.org/en/Theme_credits</a></p><h3>Theme Documentation:</h3><p><a href="http://docs.moodle.org/en/Themes">http://docs.moodle.org/en/Themes</a></p><h3>Report a bug:</h3><p><a href="http://tracker.moodle.org">http://tracker.moodle.org</a></p></div><div class="theme_description"><h2>About</h2><p>Sky High is a fluid-width, three-column theme for Moodle 2.0.<h2>Tweaks</h2><p>This theme is built upon both Base and Canvas, two parent themes included in the Moodle core. If you want to modify this theme, we recommend that you first duplicate it then rename it before making your changes. This will prevent your customized theme from being overwritten by future Moodle upgrades, and you\'ll still have the original files if you make a mess. More information on modifying themes can be found in the <a href="http://docs.moodle.org/en/Theme">MoodleDocs</a>.</p><h2>Credits</h2>	<p>This theme was designed by Julian Ridden (julian@moodle.com.au). It was coded and is maintained by John Stabinger of NewSchool Learning (contact@newschoollearning.com). </p><h2>License</h2><p>This, and all other themes included in the Moodle core, are licensed under the <a href="http://www.gnu.org/licenses/gpl.html">GNU General Public License</a>.</div></div>';
      
      Show
      In the skyhigh lang/en/theme_sky_high.php file edit the lines $string['choosereadme'] = '<div class= "clearfix" ><div class= "theme_screenshot" ><h2>Sky High</h2><img src= "sky_high/pix/screenshot.png" /><h3>Theme Discussion Forum:</h3><p><a href= "http: //moodle.org/mod/forum/view.php?id=46" >http://moodle.org/mod/forum/view.php?id=46</a></p><h3>Theme Credits</h3><p><a href= "http://docs.moodle.org/en/Theme_credits" >http://docs.moodle.org/en/Theme_credits</a></p><h3>Theme Documentation:</h3><p><a href= "http://docs.moodle.org/en/Themes" >http://docs.moodle.org/en/Themes</a></p><h3>Report a bug:</h3><p><a href= "http://tracker.moodle.org" >http://tracker.moodle.org</a></p></div><div class= "theme_description" ><h2>About</h2><p>Serenity is a fluid-width, three-column theme for Moodle 2.0.<h2>Tweaks</h2><p>This theme is built upon both Base and Canvas, two parent themes included in the Moodle core. If you want to modify this theme, we recommend that you first duplicate it then rename it before making your changes. This will prevent your customized theme from being overwritten by future Moodle upgrades, and you\'ll still have the original files if you make a mess. More information on modifying themes can be found in the <a href= "http://docs.moodle.org/en/Theme" >MoodleDocs</a>.</p><h2>Credits</h2> <p>This theme was designed by Julian Ridden (julian@moodle.com.au). It was coded and is maintained by John Stabinger of NewSchool Learning (contact@newschoollearning.com). </p><h2>License</h2><p>This, and all other themes included in the Moodle core, are licensed under the <a href= "http://www.gnu.org/licenses/gpl.html" >GNU General Public License</a>.</div></div>'; to $string['choosereadme'] = '<div class= "clearfix" ><div class= "theme_screenshot" ><h2>Sky High</h2><img src= "sky_high/pix/screenshot.png" /><h3>Theme Discussion Forum:</h3><p><a href= "http: //moodle.org/mod/forum/view.php?id=46" >http://moodle.org/mod/forum/view.php?id=46</a></p><h3>Theme Credits</h3><p><a href= "http://docs.moodle.org/en/Theme_credits" >http://docs.moodle.org/en/Theme_credits</a></p><h3>Theme Documentation:</h3><p><a href= "http://docs.moodle.org/en/Themes" >http://docs.moodle.org/en/Themes</a></p><h3>Report a bug:</h3><p><a href= "http://tracker.moodle.org" >http://tracker.moodle.org</a></p></div><div class= "theme_description" ><h2>About</h2><p>Sky High is a fluid-width, three-column theme for Moodle 2.0.<h2>Tweaks</h2><p>This theme is built upon both Base and Canvas, two parent themes included in the Moodle core. If you want to modify this theme, we recommend that you first duplicate it then rename it before making your changes. This will prevent your customized theme from being overwritten by future Moodle upgrades, and you\'ll still have the original files if you make a mess. More information on modifying themes can be found in the <a href= "http://docs.moodle.org/en/Theme" >MoodleDocs</a>.</p><h2>Credits</h2> <p>This theme was designed by Julian Ridden (julian@moodle.com.au). It was coded and is maintained by John Stabinger of NewSchool Learning (contact@newschoollearning.com). </p><h2>License</h2><p>This, and all other themes included in the Moodle core, are licensed under the <a href= "http://www.gnu.org/licenses/gpl.html" >GNU General Public License</a>.</div></div>';
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_21_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE
    • Pull from Repository:
    • Rank:
      26120

      Description

      When SkyHigh theme is selected, the text on the Read Me page refers to the Serenity theme

      'About
      Serenity is a fluid-width, three-column theme for Moodle 2.0.'

        Activity

        Michael de Raadt added a comment -

        Thanks for reporting that and providing a solution.

        Mary Evans added a comment -

        All done and dusted!

        Eloy Lafuente (stronk7) added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        PS: Note this is the last message of this type that you will receive along the whole November month, because we are running continuous integration this weeks while QA tests for release of Moodle 2.2 (Dec 1st) are being performed.

        Sam Hemelryk added a comment -

        Thanks Mary - this has been integrated now, I've also cherry-picked to the stable branches.

        Cheers
        Sam

        Sam Hemelryk added a comment -

        Tested during integration

        Eloy Lafuente (stronk7) added a comment -

        And this has landed upstream, just on time for the upcoming new releases week. Thanks for it!

        Ciao


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: