Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30223

AICC - error reported when editing AICC package

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.2, 2.2
    • Fix Version/s: 2.1.3
    • Component/s: SCORM
    • Labels:
    • Testing Instructions:

      There's no easy way to reproduce this error - I haven't been able to reproduce it using the AICC packages I have - but I received an e-mail with the report from a user and I can see the code is wrong. - so here's the patch!

      I guess the only thing that can be done is test the updating of a SCORM AICC package...

      eg grab a copy of the AICC package from:
      http://tracker.moodle.org/browse/MDL-27036
      Add this to your page, then go back and edit it again and resave - check to make sure no errors appear in the apache error log or on screen

      Show
      There's no easy way to reproduce this error - I haven't been able to reproduce it using the AICC packages I have - but I received an e-mail with the report from a user and I can see the code is wrong. - so here's the patch! I guess the only thing that can be done is test the updating of a SCORM AICC package... eg grab a copy of the AICC package from: http://tracker.moodle.org/browse/MDL-27036 Add this to your page, then go back and edit it again and resave - check to make sure no errors appear in the apache error log or on screen
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Pull Master Branch:
      master_MDL-30223

      Description

      When editing an existing SCORM AICC package:
      Coding error detected, it must be fixed by a programmer: moodle_database::update_record_raw() id field must be specified.
      Stack trace:
      • line 975 of /lib/dml/mysqli_native_moodle_database.php: coding_exception thrown
      • line 1031 of /lib/dml/mysqli_native_moodle_database.php: call to mysqli_native_moodle_database->update_record_raw()
      • line 240 of /mod/scorm/datamodels/aicclib.php: call to mysqli_native_moodle_database->update_record()
      • line 231 of /mod/scorm/locallib.php: call to scorm_parse_aicc()
      • line 207 of /mod/scorm/lib.php: call to scorm_parse()
      • line 327 of /course/modedit.php: call to scorm_update_instance()

        Gliffy Diagrams

          Activity

          stronk7 Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          PS: Note this is the last message of this type that you will receive along the whole November month, because we are running continuous integration this weeks while QA tests for release of Moodle 2.2 (Dec 1st) are being performed.

          danmarsden Dan Marsden added a comment -

          rebased - thanks.

          stronk7 Eloy Lafuente (stronk7) added a comment -

          Integrated, thanks!

          ankit_frenz Ankit Agarwal added a comment -

          works as expected
          Thanks

          stronk7 Eloy Lafuente (stronk7) added a comment -

          And this has landed upstream, just on time for the upcoming new releases week. Thanks for it!

          Ciao


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                28/Nov/11