Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30270

A few small interface issues with the rubric form editor

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2
    • Component/s: Grading methods
    • Labels:
    • Testing Instructions:

      run MDLQA-1422 and make sure that:
      1) "Current rubric status" line does not appear when creating rubric
      2) When editing rubric "Current rubric status" looks similar to status on manage.php page
      3) When creating a rubric there is already an empty criterion with three levels
      4) When editing descriptions/definitions try navigating in rubric editor with Tab key in browsers on Mac or in any browser you can think of. Hopefully both mouse click and Tab should work on PC and Mac and touch should work on IPad.
      5) Check that everything works without JavaScript

      Show
      run MDLQA-1422 and make sure that: 1) "Current rubric status" line does not appear when creating rubric 2) When editing rubric "Current rubric status" looks similar to status on manage.php page 3) When creating a rubric there is already an empty criterion with three levels 4) When editing descriptions/definitions try navigating in rubric editor with Tab key in browsers on Mac or in any browser you can think of. Hopefully both mouse click and Tab should work on PC and Mac and touch should work on IPad. 5) Check that everything works without JavaScript
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull Master Branch:
      wip-MDL-30270-master

      Description

      A few small things need polish in the rubric editor (/grade/grading/form/rubric/edit.php?areaid=1):

      1) "Current rubric status" sometimes has nothing beside it (no status). In those cases it would be better not to have this element at all.
      2) When it does have a status, can you make it look the same as the one on the overview screen? eg green/yellow CSS box around it
      3) On a brand-new form, instead of just the "Add a criterion" button, can you act as though that has been clicked and just start with one empty row, ready to edit?
      4) Regression: Tabbing seems to be broken in this form, unfortunately. I can no longer tab around in Firefox to edit the cells.

        Gliffy Diagrams

          Issue Links

            Activity

            dougiamas Martin Dougiamas added a comment -

            Discovered from MDLQA-1422

            marina Marina Glancy added a comment -

            rubric interface/usability improvements:

            • In rubric editor the line 'Current rubric status' is hidden if there is no status yet
            • If present the style of the status is the same as on manage.php page
            • For newly created rubric 'Add criterion' button is pre-pressed automatically
            • Changed JavaScript to work for Mac browsers default settings and for IPad
            • MDL-30269: added explanation message about score to grade mapping
            • fixed bug with non-javascript 'Add criterion' behaviour
            samhemelryk Sam Hemelryk added a comment -

            Hi Marina, I'm stopping this review presently.
            Could you please add testing instructions to this. Because of the tight cycle this won't get integrated until there are testing instructions.
            As for changes that only thing that needs to be changed in regards to these changes is the use of -moz-border-radius in styles.css. The rest of that declaration is fine however the border radius needs to be removed from there and if desired added to the standard theme (styles.css should only contain essential styles). At the same time the webkit declaration and CSS3 border-radius definitions should be removed.
            Could you please do this, or if you prefer I will do so during integration

            Cheers
            Ssm

            samhemelryk Sam Hemelryk added a comment -

            This has been integrated now

            samhemelryk Sam Hemelryk added a comment -

            Tested during integration on a fresh site (I had the old table structures from pre-integration of advanced grading).
            Please note I think this should still be tested by MDLQA-1422.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Closing as fixed, many thanks for your effort!

            Note that the changes related to master (2.2beta) have been already sent upstream. But the stable ones will be part of next weeklies (Wed/Thu) as usual.

            Ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/Dec/11