Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-30279

A history of each wiki page is available without the date in all the edits/changes.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2
    • Component/s: Wiki (2.x)
    • Labels:

      Description

      1. Login as student1 and access a wiki activity.
      2. Edit the page and add a tag.
      3. Add a page comment.
      4. Login as student2 and edit the same page.
      5. Login as student3 and edit the same page.
      6. Check that the history shows a list of page changes together with the user and time; but the date is shown only for the most recent edit. It should show for all the edits.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              Thanks for being involved in testing and spotting this.

              ankit_frenz Ankit Agarwal added a comment - - edited

              The date is not displayed when the changes are made on the same day. when the changes are spread over multiple days, the date is displayed along with time.
              This seems more like an expected behavior, rather than a bug. Anyway this should be clearly mentioned in the testing instructions.
              Attaching screen
              Thanks

              ankit_frenz Ankit Agarwal added a comment -

              changing assignee as they were reverted because of error.

              mayank_gupta2005 Mayank Gupta added a comment -

              Thanks for pointing that out Ankit, but before reporting it I had checked it with the Moodle Docs. It shows the dates for all the edits, whether on the same day or different.
              I think the history should show dates with all edits, to avoid any sort of confusion in case of many edits on the same day (for several days). It would definitely make the history easily readable/interpret-able.

              Thanks,
              Mayank.

              tsala Helen Foster added a comment -

              It's only a small usability issue, however I agree with Mayank that the history should show the date for all edits as it's rather confusing otherwise.

              cfulton Charles Fulton added a comment -

              I agree with Helen and Mayank; I too would expect the wiki (like Mediawiki, for example) to display the full date. I think someone could easily assume that the absence meant that the edit was the current day, if there weren't edits spaced out over multiple days to serve as a guide. Here's a patch against 2.2: https://github.com/mackensen/moodle/compare/master...MDL-30279.

              ankit_frenz Ankit Agarwal added a comment -

              This is what was decided and agreed:-
              Copying from the linked issue:-
              If there are multiple changes made on same day, currently only the most recent change displays date and rest displays only time. Since the entities are not grouped together properly they are a bit confusing for the user.
              So MDL-30279 would be fixed to temporarily display all dates and MDL-30317 is created to improve this display in future, so that we are not showing duplicate dates on the history tab.

              phalacee Jason Fowler added a comment -

              Code looks great ankit, makes sense, and is good to go

              ankit_frenz Ankit Agarwal added a comment -

              Great!
              Thanks Jason for review. Submitting for integration
              Thanks

              nebgor Aparup Banerjee added a comment -

              this has been integrated into master ONLY.
              I've tested and it works for me.
              please create a new issue for this patch to be backported into stable branches in next weekly cycle.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Closing as fixed, many thanks for your effort!

              Note that the changes related to master (2.2beta) have been already sent upstream. But the stable ones will be part of next weeklies (Wed/Thu) as usual.

              Ciao


                People

                • Votes:
                  2 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    5/Dec/11