Moodle
  1. Moodle
  2. MDL-30287

overriding grades with ajax enabled doesn't change the grade.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.2
    • Component/s: Gradebook
    • Labels:
    • Testing Instructions:

      Go into a course that contains at least one assessment and at least one student who has an actual grade for that assessment.

      Log in as a teacher. Enable ajax on the grader report (its a site setting. search for "ajax")

      Next go to [Course administration->Grades]
      Hover over a grade, click in the box, change the grade and press enter.
      If the grade wasnt previously overriden the box colour should change to indicate that the grade has been overwritten. If you reload the page your overriden grade should still be there.

      Show
      Go into a course that contains at least one assessment and at least one student who has an actual grade for that assessment. Log in as a teacher. Enable ajax on the grader report (its a site setting. search for "ajax") Next go to [Course administration->Grades] Hover over a grade, click in the box, change the grade and press enter. If the grade wasnt previously overriden the box colour should change to indicate that the grade has been overwritten. If you reload the page your overriden grade should still be there.
    • Workaround:

      Turn editing on, and override the grade.

      Show
      Turn editing on, and override the grade.
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Pull Master Branch:
      MDL-30287_grader_ajax
    • Rank:
      32628

      Description

      From testing http://tracker.moodle.org/browse/MDLQA-1333

      Please note that you can't just overwrite the grade to reproduce this problem.

      To reproduce this problem you will need to set up a course. Include an assessment (assignment, quiz etc.) log in as a student. Complete the assessment, log back in as a teacher and then grade the assessment. Next you need to enable ajax for marking. Go to [Site administration->Grades->Report settings ->Grader report] and check "Enable AJAX".

      Next go to [Course administration->Grades]
      Hover over a grade, the mouse should change to an edit icon. click in the box, change the grade and press enter.
      The grade has changed, but the overall average is the same. If the grade had saved then the box colour should change to indicate that the grade has been overwritten. If you reload the page you can see that the grade has reverted back to the original value.

      Checked with firefox 7.0.1 and google chrome 15.0.874.120.

        Issue Links

          Activity

          Andrew Davis added a comment -

          This looks like it might be another instance of the problem that caused MDL-29333. From memory the YUI version upgrade broke some of our JS and it needs reworking to work with the new version.

          Andrew Davis added a comment -

          Think Ive got this fixed. Putting it up for peer review. Youre probably better off looking at the actual code file rather than the diff.

          Andrew Davis added a comment -

          Apologies for mixing bug fixing and refactoring in the one commit. I renamed the variable "outcome" to "response" as it is the response from the server and also using the word outcome suggested that moodle outcomes were involved which they are not.

          Andrew Davis added a comment -

          Both Jason and Tim have had a look and said this looks like its good to go. The only issue they raised was the intermingling of refactoring and bug fixing that I mentioned in my previous comment.

          Andrew Davis added a comment - - edited

          Aparup has requested I split out the 2.1 and 2.0 versions so that they can be tested independently of the version going into the upcoming 2.2 release. See MDL-30473

          Aparup Banerjee added a comment -

          thanks, this has been integrated into master, tested and it works for me.
          ready for QA testing.

          Aparup Banerjee added a comment -

          works for me - go for QA test!

          Eloy Lafuente (stronk7) added a comment -

          The master fixes corresponding to this issue have been sent upstream. Fixes for other branches (19, 20, 21 stable) will be sent in the very-next days.

          Thanks for the hard work! Closing, ciao


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: