Moodle
  1. Moodle
  2. MDL-30289

Page display issue when splitting a discussion

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.5, 2.1.2, 2.2
    • Fix Version/s: 2.0.6, 2.1.3
    • Component/s: Forum
    • Labels:
    • Environment:
      qa.moodle.net

      Description

      This was discovered in MDLQA-1191. When splitting a discussion the following error is displayed:
      Coding problem: $PAGE->context was not set. You may have forgotten to call require_login() or $PAGE->set_context(). The page may not display correctly as a result
      line 345 of /lib/pagelib.php: call to debugging()
      line 617 of /lib/pagelib.php: call to moodle_page->magic_get_context()
      line 1216 of /lib/weblib.php: call to moodle_page->__get()
      line 463 of /mod/forum/post.php: call to format_string()

      This patch seems to fix it (I'm not totally clear on the mechanics of $PAGE): https://github.com/mackensen/moodle/compare/master...MDL-30289

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            Michael de Raadt added a comment -

            Thanks for being involved in testing and reporting that.

            We should be able to clear that up swiftly.

            Show
            Michael de Raadt added a comment - Thanks for being involved in testing and reporting that. We should be able to clear that up swiftly.
            Hide
            Adrian Greeve added a comment -

            Tested in 1.9, 2.0, 2.1
            This doesn't effect version 1.9

            Show
            Adrian Greeve added a comment - Tested in 1.9, 2.0, 2.1 This doesn't effect version 1.9
            Hide
            Jason Fowler added a comment -

            Code looks good

            Show
            Jason Fowler added a comment - Code looks good
            Hide
            Aparup Banerjee added a comment - - edited

            Thanks this has been integrated. Please test the 2.x STABLE branches. I'm resetting MDLQA-1191 now too (edit : or not resetting, theres still one more issue for that QA test).

            Show
            Aparup Banerjee added a comment - - edited Thanks this has been integrated. Please test the 2.x STABLE branches. I'm resetting MDLQA-1191 now too (edit : or not resetting, theres still one more issue for that QA test).
            Hide
            Ankit Agarwal added a comment -

            tested on all three branches, working as expected
            Thanks

            Show
            Ankit Agarwal added a comment - tested on all three branches, working as expected Thanks
            Hide
            Eloy Lafuente (stronk7) added a comment -

            Closing as fixed, many thanks for your effort!

            Note that the changes related to master (2.2beta) have been already sent upstream. But the stable ones will be part of next weeklies (Wed/Thu) as usual.

            Ciao

            Show
            Eloy Lafuente (stronk7) added a comment - Closing as fixed, many thanks for your effort! Note that the changes related to master (2.2beta) have been already sent upstream. But the stable ones will be part of next weeklies (Wed/Thu) as usual. Ciao

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: